kernel: bump 4.9 to 4.9.148
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 7 Jan 2019 10:03:29 +0000 (11:03 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 7 Jan 2019 16:09:06 +0000 (17:09 +0100)
Refreshed all patches.

Altered patches:
- 902-debloat_proc.patch

Removed upstreamed:
- 424-v4.20-net-dsa-fix-88e6060-roaming.patch

Compile-tested on: ar7
Runtime-tested on: none

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.9/100-arm-cns3xxx-fix-writing-to-wrong-PCI-registers-after.patch
target/linux/generic/backport-4.9/424-v4.20-net-dsa-fix-88e6060-roaming.patch [deleted file]
target/linux/generic/hack-4.9/902-debloat_proc.patch
target/linux/generic/pending-4.9/834-ledtrig-libata.patch

index 4d7397302e601879100ea5cf4e6d7600be760f53..ade18d80875fe98bdda9f4edc278c0176aa05571 100644 (file)
@@ -3,12 +3,12 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .131
-LINUX_VERSION-4.9 = .146
+LINUX_VERSION-4.9 = .148
 LINUX_VERSION-4.14 = .90
 LINUX_VERSION-4.19 = .9
 
 LINUX_KERNEL_HASH-3.18.131 = 04600ce96e4c7642b9eaa4814f4930c79b53010b1c155d23e5ac0aeba6f455e2
-LINUX_KERNEL_HASH-4.9.146 = 58195a8be3085d117c83a2ed1caa3b46ea7c1614c75f951b9f13f7adb03f8e59
+LINUX_KERNEL_HASH-4.9.148 = 6067151b0225a8de1ab79abc9be7bae237eaca0cd838eb26684169560d88a994
 LINUX_KERNEL_HASH-4.14.90 = 0c1ed0c93085e44ad89cd279647b0e4617d06ce5a482213b5481b612ffa186ca
 LINUX_KERNEL_HASH-4.19.9 = fc116cc6829c73944215d3b3ac0fc368dde9e8235b456744afffde001269dbf2
 
index 458515a0b59f4e6c37e161bf19bd60dca4a5d738..faeb3e417006bce6e166bc5a8426d40e81160bdd 100644 (file)
@@ -61,11 +61,9 @@ CC: stable@vger.kernel.org # v4.0+
  arch/arm/mach-cns3xxx/pcie.c | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/arch/arm/mach-cns3xxx/pcie.c b/arch/arm/mach-cns3xxx/pcie.c
-index 318394ed5c7a..5e11ad3164e0 100644
 --- a/arch/arm/mach-cns3xxx/pcie.c
 +++ b/arch/arm/mach-cns3xxx/pcie.c
-@@ -83,7 +83,7 @@ static void __iomem *cns3xxx_pci_map_bus(struct pci_bus *bus,
+@@ -83,7 +83,7 @@ static void __iomem *cns3xxx_pci_map_bus
        } else /* remote PCI bus */
                base = cnspci->cfg1_regs + ((busno & 0xf) << 20);
  
@@ -74,6 +72,3 @@ index 318394ed5c7a..5e11ad3164e0 100644
  }
  
  static int cns3xxx_pci_read_config(struct pci_bus *bus, unsigned int devfn,
--- 
-2.17.1
-
diff --git a/target/linux/generic/backport-4.9/424-v4.20-net-dsa-fix-88e6060-roaming.patch b/target/linux/generic/backport-4.9/424-v4.20-net-dsa-fix-88e6060-roaming.patch
deleted file mode 100644 (file)
index c49cbe2..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-From a74515604a7b171f2702bdcbd1e231225fb456d0 Mon Sep 17 00:00:00 2001
-From: Anderson Luiz Alves <alacn1@gmail.com>
-Date: Fri, 30 Nov 2018 21:58:36 -0200
-Subject: [PATCH] mv88e6060: disable hardware level MAC learning
-
-Disable hardware level MAC learning because it breaks station roaming.
-When enabled it drops all frames that arrive from a MAC address
-that is on a different port at learning table.
-
-Signed-off-by: Anderson Luiz Alves <alacn1@gmail.com>
-Reviewed-by: Andrew Lunn <andrew@lunn.ch>
-Signed-off-by: David S. Miller <davem@davemloft.net>
----
- drivers/net/dsa/mv88e6060.c | 10 +++-------
- 1 file changed, 3 insertions(+), 7 deletions(-)
-
---- a/drivers/net/dsa/mv88e6060.c
-+++ b/drivers/net/dsa/mv88e6060.c
-@@ -114,8 +114,7 @@ static int mv88e6060_switch_reset(struct
-       /* Reset the switch. */
-       REG_WRITE(REG_GLOBAL, GLOBAL_ATU_CONTROL,
-                 GLOBAL_ATU_CONTROL_SWRESET |
--                GLOBAL_ATU_CONTROL_ATUSIZE_1024 |
--                GLOBAL_ATU_CONTROL_ATE_AGE_5MIN);
-+                GLOBAL_ATU_CONTROL_LEARNDIS);
-       /* Wait up to one second for reset to complete. */
-       timeout = jiffies + 1 * HZ;
-@@ -140,13 +139,10 @@ static int mv88e6060_setup_global(struct
-        */
-       REG_WRITE(REG_GLOBAL, GLOBAL_CONTROL, GLOBAL_CONTROL_MAX_FRAME_1536);
--      /* Enable automatic address learning, set the address
--       * database size to 1024 entries, and set the default aging
--       * time to 5 minutes.
-+      /* Disable automatic address learning.
-        */
-       REG_WRITE(REG_GLOBAL, GLOBAL_ATU_CONTROL,
--                GLOBAL_ATU_CONTROL_ATUSIZE_1024 |
--                GLOBAL_ATU_CONTROL_ATE_AGE_5MIN);
-+                GLOBAL_ATU_CONTROL_LEARNDIS);
-       return 0;
- }
index 3095f832a27684714e4dc0e6f60620337c575456..f9a1e320986e55b755bd2eb7056c8a94c94a0814 100644 (file)
@@ -221,13 +221,14 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!root_irq_dir)
 --- a/kernel/time/timer_list.c
 +++ b/kernel/time/timer_list.c
-@@ -399,6 +399,8 @@ static int __init init_timer_list_procfs
+@@ -399,6 +399,9 @@ static int __init init_timer_list_procfs
  {
        struct proc_dir_entry *pe;
  
 +      if (IS_ENABLED(CONFIG_PROC_STRIPPED))
 +              return 0;
-       pe = proc_create("timer_list", 0444, NULL, &timer_list_fops);
++
+       pe = proc_create("timer_list", 0400, NULL, &timer_list_fops);
        if (!pe)
                return -ENOMEM;
 --- a/mm/vmalloc.c
index b2c0b4898076470aafc839e10f471bba56faefc4..4715182c6b3a4608d161678787a71d70e61fc88c 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4994,6 +5007,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4995,6 +5008,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
-@@ -5895,6 +5911,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5896,6 +5912,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5916,6 +5935,12 @@ static void ata_host_release(struct devi
+@@ -5917,6 +5936,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6362,7 +6387,23 @@ int ata_host_register(struct ata_host *h
+@@ -6363,7 +6388,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }