Ok, third round, the right one, touch the file anyway, does not break other packages
authorFlorian Fainelli <florian@openwrt.org>
Thu, 2 Nov 2006 23:16:09 +0000 (23:16 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 2 Nov 2006 23:16:09 +0000 (23:16 +0000)
SVN-Revision: 5387

include/package.mk

index c28aad82404d0710a559fa2ac7da057066ee684e..f0c5511baf33940e76a2130308f3ad759e4727f8 100644 (file)
@@ -291,13 +291,14 @@ endef
 
 define Build/Configure/Default
        (cd $(PKG_BUILD_DIR) ; \
-               [ -e configure.in ] && touch configure.in ; \
-               [ -e aclocal.m4 ] && touch aclocal.m4 ; \
-               [ -e Makefile.in ] && touch Makefile.in ; \
-               [ -e configure ] && touch configure ; \
-               [ -e acinclude.m4 ] && touch acinclude.m4 ; \
-               [ -e config.h.in ] && touch config.h.in ; \
-               [ -e configure.ac ] && touch configure.ac ; \
+               touch configure.in ; \
+               touch aclocal.m4 ; \
+               touch Makefile.in ; \
+               touch configure ; \
+               touch acinclude.m4 ; \
+               touch config.h.in ; \
+               touch configure.ac ; \
+               touch stamp-h.in ; \
        );
        (cd $(PKG_BUILD_DIR)/$(strip $(3)); \
        if [ -x configure ]; then \