mpc85xx: disable bricking TL-WDR4900v1 images
authorChristian Lamparter <chunkeey@gmail.com>
Sun, 14 Apr 2019 21:54:33 +0000 (23:54 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 14 Apr 2019 22:20:56 +0000 (00:20 +0200)
The current mpc85xx build is failing because the
TL-WDR4900v1 kernel image no longer fits into the
partition. Extending the kernel is not possible
without updating u-boot's kernel loader commands.

This patch disables the WDR4900v1 until the kernel
image size issue is fixed so the buildbot can still
compile the Sophos RED 15w Rev.1 . Installing the
WDR4900v1 images would cause the routers to get
bricked.

For the discussion, please go to:
<https://github.com/openwrt/openwrt/pull/1773>

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/mpc85xx/image/Makefile

index 68c0da84eeb2a6b6613d2c1148170d49141eee21..f95e38d5c6d2d1c49c33939a5c1cfa5f72ff430e 100644 (file)
@@ -60,7 +60,7 @@ define Device/tl-wdr4900-v1
   IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade | append-metadata
   IMAGE/factory.bin := append-rootfs | mktplinkfw factory
 endef
-TARGET_DEVICES += tl-wdr4900-v1
+#TARGET_DEVICES += tl-wdr4900-v1
 
 define Device/red-15w-rev1
   DEVICE_TITLE := Sophos RED 15w Rev.1