added a function, that packages can call to make installing files/folders much cleane...
authorJohn Crispin <john@openwrt.org>
Sun, 7 Oct 2007 01:55:03 +0000 (01:55 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 7 Oct 2007 01:55:03 +0000 (01:55 +0000)
SVN-Revision: 9171

include/package.mk

index d61eb8cf7a5d694ad3789b9a7b8218c034781abb..6307a1f47c2b41a1235298bd03b5d9e4d9e543f1 100644 (file)
@@ -121,6 +121,10 @@ define libtool_fixup_libdir
                $(SED) "s,^libdir='/usr/lib',libdir='$(strip $(1))/usr/lib',g"
 endef
 
+define pkg_install_files
+       $(foreach install_file,$(2),$(INSTALL_DIR) $(1)/`dirname $(install_file)`; $(CP) $(PKG_INSTALL_DIR)/$(install_file) $(1)/`dirname $(install_file)`;)
+endef
+
 define Build/Prepare
   $(call Build/Prepare/Default,)
 endef