uClibc: remove avr32 support
authorFelix Fietkau <nbd@openwrt.org>
Tue, 24 Mar 2015 10:07:07 +0000 (10:07 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 24 Mar 2015 10:07:07 +0000 (10:07 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 44961

toolchain/uClibc/common.mk
toolchain/uClibc/config-0.9.33.2/avr32 [deleted file]
toolchain/uClibc/patches-0.9.33.2/140-avr32_atomic_fix.patch [deleted file]

index 435e4c25116fb36e11fc7d87820f37b7823247dd..610532c8390890e7f427bcdf5a3bebbd151df9a6 100644 (file)
@@ -26,7 +26,6 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
                -e 's/i.86/i386/' \
                -e 's/sparc.*/sparc/' \
                -e 's/arm.*/arm/g' \
-               -e 's/avr32.*/avr32/g' \
                -e 's/m68k.*/m68k/' \
                -e 's/ppc/powerpc/g' \
                -e 's/v850.*/v850/g' \
diff --git a/toolchain/uClibc/config-0.9.33.2/avr32 b/toolchain/uClibc/config-0.9.33.2/avr32
deleted file mode 100644 (file)
index 729fbc9..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-ARCH_BIG_ENDIAN=y
-CONFIG_AVR32_AP7=y
-FORCE_SHAREABLE_TEXT_SEGMENTS=y
-LINKRELAX=y
-LINUXTHREADS_OLD=y
-TARGET_ARCH="avr32"
-TARGET_avr32=y
-UCLIBC_HAS_FPU=y
-# UCLIBC_HAS_SCANF_GLIBC_A_FLAG is not set
-# UCLIBC_HAS_STRING_ARCH_OPT is not set
-# UCLIBC_HAS_THREADS_NATIVE is not set
-UNIX98PTY_ONLY=y
diff --git a/toolchain/uClibc/patches-0.9.33.2/140-avr32_atomic_fix.patch b/toolchain/uClibc/patches-0.9.33.2/140-avr32_atomic_fix.patch
deleted file mode 100644 (file)
index 5e5460a..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/libc/sysdeps/linux/avr32/bits/atomic.h
-+++ b/libc/sysdeps/linux/avr32/bits/atomic.h
-@@ -28,6 +28,7 @@ typedef uintmax_t uatomic_max_t;
- #define __arch_compare_and_exchange_val_32_acq(mem, newval, oldval)   \
-       ({                                                              \
-+              __uint32_t __result;                                    \
-               __typeof__(*(mem)) __prev;                              \
-               __asm__ __volatile__(                                   \
-                       "/* __arch_compare_and_exchange_val_32_acq */\n" \