fix initscripts activation (closes: #4037, #4745)
authorNicolas Thill <nico@openwrt.org>
Tue, 21 Apr 2009 11:20:25 +0000 (11:20 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 21 Apr 2009 11:20:25 +0000 (11:20 +0000)
SVN-Revision: 15320

target/imagebuilder/files/Makefile

index e8bd28f3184f620b7e4495176963b74f293ef6e8..b52692517778fd16bb16af180922c50f1ed67418 100644 (file)
@@ -131,10 +131,10 @@ package_postinst: FORCE
        @echo
        @echo Activating init scripts
        @( \
-               cd $(BUILD_DIR)/root; \
+               cd $(TARGET_DIR); \
                for script in ./etc/init.d/*; do \
                        grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
-                       IPKG_INSTROOT=$(BUILD_DIR)/root $(which bash) ./etc/rc.common $$script enable; \
+                       IPKG_INSTROOT=$(TARGET_DIR) $(which bash) ./etc/rc.common $$script enable; \
                done || true; \
        )