ath79: Add support for Ubiquiti Nanostation M (XW)
authorPetr Štetiar <ynezz@true.cz>
Wed, 12 Dec 2018 20:09:01 +0000 (21:09 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Tue, 5 Mar 2019 02:15:52 +0000 (03:15 +0100)
CPU:  AR9342 SoC
RAM:      64 MB DDR2
Flash:     8 MB NOR SPI
Ports: 2x100 MBit (24V PoE in, 24V PoE out), AR8236 switch
WLAN:  2.4/5 GHz
UART:      1 UART
LEDs:        Power, 2x Ethernet, 4x RSSI LEDs (orange, red, 2x green)
Buttons:     Reset

Flashing instructions using recovery method over TFTP

 1. Unplug the ethernet cable from the router.
 2. Using paper clip press and hold the router's reset button. Make sure
    you can feel it depressed by the paper clip. Do not release the button
    until step 4.
 3. While keeping the reset button pressed in, plug the ethernet cable
    back into the AP. Keep the reset button depressed until you see the
    device's LEDs flashing in upgrade mode (alternating LED1/LED3 and
    LED2/LED4), this may take up to 25 seconds.
 4. You may release the reset button, now the device should be in TFTP
    transfer mode.
 5. Set a static IP on your Computer's NIC. A static IP of 192.168.1.25/24
    should work.
 6. Plug the PoE injector's LAN cable directly to your computer.
 7. Start tftp client and issue following commands:
     tftp> binary
     tftp> connect 192.168.1.20
     tftp> put openwrt-ath79-generic-ubnt-nano-m-xw-squashfs-factory.bin

Tested-by: Joe Ayers <ae6xe@arrl.net>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/dts/ar9342_ubnt_nanostation-m-xw.dts [new file with mode: 0644]
target/linux/ath79/image/generic-ubnt.mk

index 705ae3d407d982fb3ee9e5260012c3a9b46a62e7..0fa4bc73bb9d572f28b7a218941e01b43a8f34f0 100755 (executable)
@@ -149,6 +149,7 @@ tplink,tl-wr841-v11)
 ubnt,bullet-m|\
 ubnt,bullet-m-xw|\
 ubnt,nano-m|\
+ubnt,nanostation-m-xw|\
 ubnt,rocket-m)
        ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "ubnt:red:link1" "wlan0" "1" "100"
index f1171695bd3739f6e52f5e03b98d6007989df51b..9a7f2d6472b78b8a50f2e71e6a6db9c90f382205 100755 (executable)
@@ -212,6 +212,10 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth1" "2:lan:3" "3:lan:2" "4:lan:1"
                ;;
+       ubnt,nanostation-m-xw)
+               ucidef_add_switch "switch0" \
+                       "0@eth0" "5:lan" "1:wan"
+               ;;
        ubnt,nanostation-ac|\
        ubnt,unifiac-mesh-pro|\
        ubnt,unifiac-pro)
diff --git a/target/linux/ath79/dts/ar9342_ubnt_nanostation-m-xw.dts b/target/linux/ath79/dts/ar9342_ubnt_nanostation-m-xw.dts
new file mode 100644 (file)
index 0000000..6ac79b0
--- /dev/null
@@ -0,0 +1,37 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9342_ubnt_xw.dtsi"
+
+/ {
+       compatible = "ubnt,nanostation-m-xw", "ubnt,xw", "qca,ar9342";
+       model = "Ubiquiti Nanostation M (XW)";
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy4-mii-enable;
+       phy-mask = <0x23>;
+
+       phy4: ethernet-phy@0 {
+               reg = <0>;
+               phy-mode = "mii";
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-mode = "mii";
+       phy-handle = <&phy4>;
+
+       gmac-config {
+               device = <&gmac>;
+               mii-gmac0 = <1>;
+               mii-gmac0-slave = <1>;
+       };
+};
index 681c14dfb642e58428a88cc7bf5f984cc45d27df..4f0a6a500dd55bda3ba1a2fee077aa6197df291f 100644 (file)
@@ -113,6 +113,12 @@ define Device/ubnt_nano-m
 endef
 TARGET_DEVICES += ubnt_nano-m
 
+define Device/ubnt_nanostation-m-xw
+  $(Device/ubnt-xw)
+  DEVICE_TITLE := Ubiquiti Nanostation M (XW)
+endef
+TARGET_DEVICES += ubnt_nanostation-m-xw
+
 define Device/ubnt_lap-120
   $(Device/ubnt-wa)
   DEVICE_TITLE := Ubiquiti LiteAP ac (LAP-120)