cleanup & revert [4159]
authorMike Baker <mbm@openwrt.org>
Thu, 20 Jul 2006 17:15:12 +0000 (17:15 +0000)
committerMike Baker <mbm@openwrt.org>
Thu, 20 Jul 2006 17:15:12 +0000 (17:15 +0000)
SVN-Revision: 4173

openwrt/include/verbose.mk

index 16a75c08c9744ff741d46f397576d697c4a9d11f..7d9b3979bffcb171ff025375d4c1324a6ebca5ab 100644 (file)
@@ -6,11 +6,11 @@
 #
 # $Id:$
 
-NO_TRACE_MAKE:=$(MAKE) V=99
+export NO_TRACE_MAKE:=$(MAKE) V=99
 
 ifndef KBUILD_VERBOSE
   KBUILD_VERBOSE=0
-  ifdef V
+  ifeq ("$(origin V)", "command line")
     KBUILD_VERBOSE=$(V)
   endif
 endif
@@ -32,6 +32,4 @@ ifneq ($(KBUILD_VERBOSE),99)
   endif
 
   .SILENT: $(MAKECMDGOALS)
-else
-   NO_TRACE_MAKE:=$(MAKE)
 endif