libubox: update to latest Git HEAD
authorPetr Štetiar <ynezz@true.cz>
Sun, 24 Nov 2019 12:51:42 +0000 (13:51 +0100)
committerPetr Štetiar <ynezz@true.cz>
Sun, 24 Nov 2019 13:19:43 +0000 (14:19 +0100)
07413cce72e1 tests: jshn: add more test cases
26586dae43a8 jshn: fix missing usage for -p and -o arguments
8e832a771d3a jshn: fix off by one in jshn_parse_file
cb698e35409b jshn: jshn_parse: fix leaks of memory pointed to by 'obj'
c42f11cc7c0f jshn: main: fix leak of memory pointed to by 'vars'
93848ec96dc5 jshn: refactor main into smaller pieces
9b6ede0e5312 avl: guard against theoretical null pointer dereference
c008294a8323 blobmsg_json: fix possible uninitialized struct member
0003ea9c45cc base64: fix possible null pointer dereference
8baeeea1f52d add assert.h component
b0a5cd8a28bf add cram based unit tests
1fefb7c4d7f9 add initial GitLab CI support
c955464d7a9b enable extra compiler checks
6228df9de91d iron out all extra compiler warnings

Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/libs/libubox/Makefile

index 8a0533ce4c6d8dbf70762d4d55789813d0dc8023..d0009ab3de611d35c785eefceeaa6a80b741effc 100644 (file)
@@ -5,9 +5,9 @@ PKG_RELEASE=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/libubox.git
-PKG_MIRROR_HASH:=58f6f6b21a00b69d466bcbce31e8adbef364d139715731430194746be5211840
-PKG_SOURCE_DATE:=2019-10-29
-PKG_SOURCE_VERSION:=301303911dded723b7eda4d6a4a933b22d2c1b60
+PKG_MIRROR_HASH:=e7ef39ffe693d6f106aa320268d90a68aebd0a0aa1baa0051d70b3bb1f8a64fc
+PKG_SOURCE_DATE:=2019-11-24
+PKG_SOURCE_VERSION:=07413cce72e19520af55dfcbc765484f5ab41dd9
 CMAKE_INSTALL:=1
 
 PKG_LICENSE:=ISC