ramips: add build recipe for senao header
authorMathias Kresin <dev@kresin.me>
Wed, 17 Aug 2016 05:49:34 +0000 (07:49 +0200)
committerMathias Kresin <dev@kresin.me>
Wed, 17 Aug 2016 05:49:34 +0000 (07:49 +0200)
Add it to the Makefile to allow a board which will be supported soon
to use the recipe as well.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/image/Makefile

index 7b53a2f7442fcfaa92d208d1fab5240cb1fd036c..2af6d68547f21e8b839734ec6c798813484ac698 100644 (file)
@@ -78,6 +78,11 @@ define Build/umedia-header
        fix-u-media-header -T 0x46 -B $(1) -i $@ -o $@.new && mv $@.new $@
 endef
 
        fix-u-media-header -T 0x46 -B $(1) -i $@ -o $@.new && mv $@.new $@
 endef
 
+define Build/senao-header
+       $(STAGING_DIR_HOST)/bin/mksenaofw $(1) -e $@ -o $@.new
+       mv $@.new $@
+endef
+
 #
 # The real magic happens inside these templates
 #
 #
 # The real magic happens inside these templates
 #