bcm53xx: added basic dts for linksys ea6500v2
authorRene Kjellerup <rk.katana.steel@gmail.com>
Sun, 22 Oct 2017 00:19:03 +0000 (17:19 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 7 Oct 2018 00:12:06 +0000 (02:12 +0200)
only thing not working is the b43 5GHz wifi band as upstream
kernel
doesn't supporthe 0x4360 chip so far

Signed-off-by: Rene Kjellerup <rk.katana.steel@gmail.com>
target/linux/bcm53xx/image/Makefile
target/linux/bcm53xx/patches-4.14/315-ARM-dts-BCM5301X-Add-basic-DT-for-Linksys-EA6500-V2.patch [new file with mode: 0644]

index 596cb5ddb271cfa0b4a67dd2bdf41023e79b1ec8..e42d612f1f684673fa80653ca076273b45ae62f2 100644 (file)
@@ -224,13 +224,18 @@ endef
 TARGET_DEVICES += dlink-dir-885l
 
 # Linksys devices are disabled due to problem with 2 TRX partitions
-
 define Device/linksys-ea6300-v1
   DEVICE_TITLE := Linksys EA6300 V1
   DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
 endef
 # TARGET_DEVICES += linksys-ea6300-v1
 
+define Device/linksys-ea6500-v2
+  DEVICE_TITLE := Linksys EA6500 V2
+  DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += linksys-ea6500-v2
+
 define Device/linksys-ea9200
   DEVICE_TITLE := Linksys EA9200 V1
   DEVICE_PACKAGES := $(BRCMFMAC_43602A1) $(USB3_PACKAGES)
diff --git a/target/linux/bcm53xx/patches-4.14/315-ARM-dts-BCM5301X-Add-basic-DT-for-Linksys-EA6500-V2.patch b/target/linux/bcm53xx/patches-4.14/315-ARM-dts-BCM5301X-Add-basic-DT-for-Linksys-EA6500-V2.patch
new file mode 100644 (file)
index 0000000..3ac8602
--- /dev/null
@@ -0,0 +1,64 @@
+---
+ arch/arm/boot/dts/Makefile                      |  1 +
+ arch/arm/boot/dts/bcm4708-linksys-ea6500-v2.dts | 41 +++++++++++++++++++++++++
+ 2 files changed, 42 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm4708-linksys-ea6500-v2.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -82,6 +82,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+       bcm4708-asus-rt-ac68u.dtb \
+       bcm4708-buffalo-wzr-1750dhp.dtb \
+       bcm4708-linksys-ea6300-v1.dtb \
++      bcm4708-linksys-ea6500-v2.dtb \
+       bcm4708-luxul-xap-1510.dtb \
+       bcm4708-luxul-xwc-1000.dtb \
+       bcm4708-netgear-r6250.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm4708-linksys-ea6500-v2.dts
+@@ -0,0 +1,45 @@
++// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
++/*
++ * Copyright (C) 2017 Rafał Miłecki <rafal@milecki.pl>
++ * Copyright (C) 2018 Rene Kjellerup <rk.katana.steel@gmail.com>
++ *
++ */
++
++/dts-v1/;
++
++#include "bcm4708.dtsi"
++#include "bcm5301x-nand-cs0-bch8.dtsi"
++
++/ {
++      compatible = "linksys,ea6500-v2", "brcm,bcm4708";
++      model = "Linksys EA6500 V2";
++
++      chosen {
++              bootargs = "console=ttyS0,115200";
++      };
++
++      memory {
++              reg = <0x00000000 0x08000000>;
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys";
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              wps {
++                      label = "WPS";
++                      linux,code = <KEY_WPS_BUTTON>;
++                      gpios = <&chipcommon 7 GPIO_ACTIVE_LOW>;
++              };
++
++              restart {
++                      label = "Reset";
++                      linux,code = <KEY_RESTART>;
++                      gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
++              };
++      };
++};
++&usb3_phy {
++      status = "okay";
++};