package/busybox: rename 'target-config.in' to 'Config.in' for coherency, move submenu...
authorNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 10:42:10 +0000 (10:42 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 10:42:10 +0000 (10:42 +0000)
SVN-Revision: 20912

package/busybox/Config.in [new file with mode: 0644]
package/busybox/Makefile
package/busybox/target-config.in [deleted file]

diff --git a/package/busybox/Config.in b/package/busybox/Config.in
new file mode 100644 (file)
index 0000000..1002a5a
--- /dev/null
@@ -0,0 +1,39 @@
+menu "Configuration"
+       depends on PACKAGE_busybox
+
+config BUSYBOX_CONFIG_FEATURE_DEVFS
+       bool
+       default y if LINUX_2_4
+       default n if LINUX_2_6
+
+config BUSYBOX_CONFIG_FEATURE_2_4_MODULES
+       bool
+       default y if LINUX_2_4
+       default n if LINUX_2_6
+
+config BUSYBOX_CONFIG_FEATURE_2_6_MODULES
+       bool
+       default n if LINUX_2_4
+       default y if LINUX_2_6
+
+config BUSYBOX_CONFIG_NOMMU
+       bool
+       depends NOMMU
+       default y if NOMMU
+       deselect BUSYBOX_CONFIG_ASH
+       deselect BUSYBOX_CONFIG_FEATURE_SH_IS_ASH
+       deselect BUSYBOX_CONFIG_LOCK
+
+config CONFIG_BUSYBOX_CONFIG_FEATURE_SH_IS_HUSH
+       bool
+       default y if NOMMU
+       default n if !NOMMU
+
+config BUSYBOX_CONFIG_HUSH
+       bool
+       default y if NOMMU
+       default n if !NOMMU
+
+source "package/busybox/config/Config.in"
+
+endmenu
index 9638e9c5f2dbc7014f28fb18cbe6d6366ca65f3d..d13980ceb055b84cf822d90b2ad1d0ea019e1258 100644 (file)
@@ -42,11 +42,7 @@ define Package/busybox/description
 endef
 
 define Package/busybox/config
-       menu "Configuration"
-               depends on PACKAGE_busybox
-               source "$(SOURCE)/target-config.in"
-               source "$(SOURCE)/config/Config.in"
-       endmenu
+       source "$(SOURCE)/Config.in"
 endef
 
 define Build/Configure
diff --git a/package/busybox/target-config.in b/package/busybox/target-config.in
deleted file mode 100644 (file)
index b065561..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-config BUSYBOX_CONFIG_FEATURE_DEVFS
-       bool
-       default y if LINUX_2_4
-       default n if LINUX_2_6
-
-config BUSYBOX_CONFIG_FEATURE_2_4_MODULES
-       bool
-       default y if LINUX_2_4
-       default n if LINUX_2_6
-
-config BUSYBOX_CONFIG_FEATURE_2_6_MODULES
-       bool
-       default n if LINUX_2_4
-       default y if LINUX_2_6
-
-config BUSYBOX_CONFIG_NOMMU
-       bool
-       depends NOMMU
-       default y if NOMMU
-       deselect BUSYBOX_CONFIG_ASH
-       deselect BUSYBOX_CONFIG_FEATURE_SH_IS_ASH
-       deselect BUSYBOX_CONFIG_LOCK
-
-config CONFIG_BUSYBOX_CONFIG_FEATURE_SH_IS_HUSH
-       bool
-       default y if NOMMU
-       default n if !NOMMU
-
-config BUSYBOX_CONFIG_HUSH
-       bool
-       default y if NOMMU
-       default n if !NOMMU
-