generic/4.4: bump to -rc5
authorImre Kaloz <kaloz@openwrt.org>
Tue, 15 Dec 2015 11:20:38 +0000 (11:20 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Tue, 15 Dec 2015 11:20:38 +0000 (11:20 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 47894

include/kernel-version.mk
target/linux/generic/patches-4.4/834-ledtrig-libata.patch
target/linux/generic/patches-4.4/863-gpiommc.patch
target/linux/generic/patches-4.4/902-debloat_proc.patch
target/linux/generic/patches-4.4/997-device_tree_cmdline.patch
target/linux/mvebu/patches-4.4/000-sata_use_ifdef_around_suspend_resume.patch [deleted file]

index 201c2a9b16b7fe715869ede9c6ffad9f6d327ecb..b5b5fc48cea6c8d2be36de3db90fe6670403b265 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .23
 LINUX_VERSION-4.1 = .13
 LINUX_VERSION-4.3 =
-LINUX_VERSION-4.4 = -rc4
+LINUX_VERSION-4.4 = -rc5
 
 LINUX_KERNEL_MD5SUM-3.18.23 = dc6d265ab38716be3676ac294b481ad8
 LINUX_KERNEL_MD5SUM-4.1.13 = af9dd5d8f71185a64a8eccface15fc00
 LINUX_KERNEL_MD5SUM-4.3 = 58b35794eee3b6d52ce7be39357801e7
-LINUX_KERNEL_MD5SUM-4.4-rc4 = 893caa049cd5c680bf6770603d6cb416
+LINUX_KERNEL_MD5SUM-4.4-rc5 = 7516a83ce861c7b2324975c82c413157
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 6c6e78e005f89e3bf98b7fb306d688e8524c608c..c60fc1a51510020f39aefedff9e7df333c46e994 100644 (file)
@@ -138,7 +138,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
  /*
   * Define if arch has non-standard setup.  This is a _PCI_ standard
-@@ -876,6 +879,12 @@ struct ata_port {
+@@ -877,6 +880,12 @@ struct ata_port {
  #ifdef CONFIG_ATA_ACPI
        struct ata_acpi_gtm     __acpi_init_gtm; /* use ata_acpi_init_gtm() */
  #endif
index de112d407b7a4fbceddac9e1f761ee0d3ac998a1..55982b65b5e44186d5c5b961bcee3557aae81a28 100644 (file)
 +be done automatically.
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -4879,6 +4879,11 @@ T:      git git://linuxtv.org/anttip/media_tr
+@@ -4880,6 +4880,11 @@ T:      git git://linuxtv.org/anttip/media_tr
  S:    Maintained
  F:    drivers/media/usb/hackrf/
  
index 2d7cc5d904963f1dbde182fa86d71c9c624e66dc..57ceeae82c54a66ed657ce6c61a55de31b96cc00 100644 (file)
  }
 --- a/mm/vmstat.c
 +++ b/mm/vmstat.c
-@@ -1551,10 +1551,12 @@ static int __init setup_vmstat(void)
-       cpu_notifier_register_done();
+@@ -1553,10 +1553,12 @@ static int __init setup_vmstat(void)
+       vmstat_wq = alloc_workqueue("vmstat", WQ_FREEZABLE|WQ_MEM_RECLAIM, 0);
  #endif
  #ifdef CONFIG_PROC_FS
 -      proc_create("buddyinfo", S_IRUGO, NULL, &fragmentation_file_operations);
index 2ea41497a9e17fc313798e4b99e4fce28d1a0c8f..566648fcc504efc5a3dc50fb8310c9872cc40b95 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/of/fdt.c
 +++ b/drivers/of/fdt.c
-@@ -951,6 +951,9 @@ int __init early_init_dt_scan_chosen(uns
+@@ -956,6 +956,9 @@ int __init early_init_dt_scan_chosen(uns
        p = of_get_flat_dt_prop(node, "bootargs", &l);
        if (p != NULL && l > 0)
                strlcpy(data, p, min((int)l, COMMAND_LINE_SIZE));
diff --git a/target/linux/mvebu/patches-4.4/000-sata_use_ifdef_around_suspend_resume.patch b/target/linux/mvebu/patches-4.4/000-sata_use_ifdef_around_suspend_resume.patch
deleted file mode 100644 (file)
index ba0bd96..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-The newly added suspend/resume implementation for ahci_mvebu causes
-a link error when CONFIG_PM_SUSPEND is disabled:
-
-ERROR: "ahci_platform_suspend_host" [drivers/ata/ahci_mvebu.ko] undefined!
-ERROR: "ahci_platform_resume_host" [drivers/ata/ahci_mvebu.ko] undefined!
-
-This adds the same #ifdef here that exists in the ahci_platform driver
-which defines the above functions.
-
-Signed-off-by: Arnd Bergmann <arnd@arndb.de>
-Fixes: d6ecf1581488 ("ata: ahci_mvebu: add suspend/resume support")
-Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
---- a/drivers/ata/ahci_mvebu.c
-+++ b/drivers/ata/ahci_mvebu.c
-@@ -62,6 +62,7 @@ static void ahci_mvebu_regret_option(str
-       writel(0x80, hpriv->mmio + AHCI_VENDOR_SPECIFIC_0_DATA);
- }
-+#ifdef CONFIG_PM_SLEEP
- static int ahci_mvebu_suspend(struct platform_device *pdev, pm_message_t state)
- {
-       return ahci_platform_suspend_host(&pdev->dev);
-@@ -81,6 +82,10 @@ static int ahci_mvebu_resume(struct plat
-       return ahci_platform_resume_host(&pdev->dev);
- }
-+#else
-+#define ahci_mvebu_suspend NULL
-+#define ahci_mvebu_resume NULL
-+#endif
- static const struct ata_port_info ahci_mvebu_port_info = {
-       .flags     = AHCI_FLAG_COMMON,