bugfixes
authorMike Baker <mbm@openwrt.org>
Mon, 28 Feb 2005 07:04:51 +0000 (07:04 +0000)
committerMike Baker <mbm@openwrt.org>
Mon, 28 Feb 2005 07:04:51 +0000 (07:04 +0000)
SVN-Revision: 296

openwrt/Makefile
openwrt/package/openwrt/openwrt.mk
openwrt/target/default/target_skeleton/etc/preinit
openwrt/target/jffs2/jffs2root.mk

index b8c9b10b7068b644538aeaa550fa85cbe49f4e36..e490078bc5971123ac6b7a37fad3ad6e1eb175e1 100644 (file)
@@ -48,8 +48,7 @@ ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
 # along with the packages to build for the target.
 #
 ##############################################################
-TARGETS:=host-sed kernel-headers uclibc-configured binutils gcc uclibc-target-utils
-TARGETS+=openwrt-sstrip linux
+TARGETS:=host-sed kernel-headers uclibc-configured binutils gcc uclibc-target-utils linux openwrt
 
 include toolchain/Makefile.in
 include package/Makefile.in
@@ -118,7 +117,7 @@ $(TARGET_DIR):
        fi;
        -find $(TARGET_DIR) -type d -name CVS | xargs rm -rf
        -find $(TARGET_DIR) -type d -name .svn | xargs rm -rf
-       -ln -sf /tmp/resolv.conf $(TARGET_DIR)
+       -ln -sf /tmp/resolv.conf $(TARGET_DIR)/etc
        -mkdir -p $(TARGET_DIR)/jffs
 
 source: $(TARGETS_SOURCE)
@@ -226,3 +225,5 @@ endif # ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
 .PHONY: dummy subdirs release distclean clean config oldconfig \
        menuconfig tags check test depend
 
+targets:
+       @echo $(TARGETS)
index dcb4c3334b86c54ba8387cb8f3d55038f9cb1aca..935fe16e7ce3646024fe622fc4787a73f6cc84c2 100644 (file)
@@ -160,7 +160,7 @@ STRIP=$(OPENWRT_SSTRIP_TARGET)
 
 linksys:       linksys-shared linksys-nvram linksys-wlconf
 
-openwrt:       linksys openwrt-mtd openwrt-trx openwrt-addpattern openwrt-jffs2root
+openwrt:       linksys openwrt-mtd openwrt-trx openwrt-addpattern openwrt-jffs2root openwrt-sstrip
 
 openwrt-dirclean: linksys-shared-dirclean linksys-nvram-dirclean linksys-wlconf-dirclean
 
index 28fe8052609764a339ac7b0cfee9284e4cc837f1..30c025be292707f3839009446f08ba174c28f7a1 100755 (executable)
@@ -1,5 +1,6 @@
 #!/bin/sh
 mount none /proc -t proc
+mount none /tmp -t ramfs
 insmod diag
 echo 0x01 > /proc/sys/diag
 sleep 1
@@ -7,14 +8,16 @@ if [ $(cat /proc/sys/reset) = 1 ] ; then
   export FAILSAFE=true
   while :; do { echo $(((X=(X+1)%8)%2)) > /proc/sys/diag; sleep $((X==0)); } done &
 else
-  mount | grep jffs2 1>&- || {
+  mount | grep jffs2 >&-
+  if [ $? = 0 ] && [ $(cat /proc/mtd | wc -l) = 6 ] ; then
+    jffs2root --move && reboot 
+  else
     mtd unlock mtd4
     mount -t jffs2 /dev/mtdblock/4 /jffs
     pivot_root /jffs /jffs/rom
-  }
-  mount none /dev -t devfs
-  mount none /proc -t proc
-  umount rom/proc
+    mount none /dev -t devfs
+    mount none /proc -t proc
+    umount rom/proc
+  fi
 fi
-mount none /tmp -t ramfs
 exec /sbin/init
index 8dcd00f572d11367cc3d61ad42d475caa9c8f28e..92dad0e57c03e2968dcaa0ca9b1453a849790ad2 100644 (file)
@@ -29,8 +29,7 @@ mtd: $(MKFS_JFFS2)
 #############################################################
 
 jffs2root: mtd
-       #-@find $(TARGET_DIR)/lib -type f -name \*.so\* | xargs $(STRIP) --strip-unneeded 2>/dev/null || true;
-       -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
+       -@find $(TARGET_DIR) -type f -perm +111 | xargs $(SSTRIP) 2>/dev/null || true;
        @rm -rf $(TARGET_DIR)/usr/man
        @rm -rf $(TARGET_DIR)/usr/info
        $(MKFS_JFFS2) --pad --little-endian --squash -e 0x20000 \