build: drop FIT option until we actually need it
authorLuka Perkov <luka@openwrt.org>
Thu, 17 Oct 2013 15:45:41 +0000 (15:45 +0000)
committerLuka Perkov <luka@openwrt.org>
Thu, 17 Oct 2013 15:45:41 +0000 (15:45 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38439

Config.in
scripts/metadata.pl
target/Config.in
target/linux/imx6/Makefile

index 7683a8bc417c0804af88169681ca94ec85cc3908..a7ef477b200091b13079253b52a352f784312e9d 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -189,15 +189,6 @@ menu "Target Images"
                  Include the device tree blob file(s) in the rootfs. Typically the DTBs
                  are placed below /boot.
 
-       comment "Image Type"
-
-       config TARGET_IMAGE_FIT
-               bool "FIT image with kernel and DTB"
-               default y if USES_FIT
-               depends on USES_FIT
-               help
-                  Create a u-boot FIT image containing kernel and DTB
-
 endmenu
 
 menu "Global build settings"
index 04fa827c647626efc41b5245ce3190f1475e13e1..ddcf50bf32a3b9a1e0ab4770b4a97443787e109e 100755 (executable)
@@ -172,7 +172,6 @@ sub target_config_features(@) {
                /targz/ and $ret .= "\tselect USES_TARGZ\n";
                /cpiogz/ and $ret .= "\tselect USES_CPIOGZ\n";
                /ubifs/ and $ret .= "\tselect USES_UBIFS\n";
-               /fit/ and $ret .= "\tselect USES_FIT\n";
                /fpu/ and $ret .= "\tselect HAS_FPU\n";
                /spe_fpu/ and $ret .= "\tselect HAS_SPE_FPU\n";
                /ramdisk/ and $ret .= "\tselect USES_INITRAMFS\n";
index 94c10bb34d73ea9a249c1ffc9534e926a3300018..7f694e4c8badc436bc76d4d124322d9cecee9818 100644 (file)
@@ -63,9 +63,6 @@ config USES_CPIOGZ
 config USES_UBIFS
        bool
 
-config USES_FIT
-       bool
-
 config PROFILE_KCONFIG
        bool
 
index ef4f08fa48846972d30bcdb2898f58e12f113cac..4a9bc8cb3cf1f8263a9bf29309c6e1d0aa92a179 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=imx6
 BOARDNAME:=Freescale i.MX 6 Series
-FEATURES:=audio display gpio pcie usb usbgadget fit squashfs targz
+FEATURES:=audio display gpio pcie usb usbgadget squashfs targz
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>