Enable recursive download of git sources.
authorJens Muecke <jens@nons.de>
Sat, 17 Mar 2012 21:33:13 +0000 (21:33 +0000)
committerJens Muecke <jens@nons.de>
Sat, 17 Mar 2012 21:33:13 +0000 (21:33 +0000)
SVN-Revision: 30967

include/download.mk

index 7009bfcd44c58d18fb8b92fdbe72aea84fbce515..6cc10d95c3057e49fe17454f0873cbc67608b17d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -87,7 +87,7 @@ define DownloadMethod/git
                cd $(TMP_DIR)/dl && \
                rm -rf $(SUBDIR) && \
                [ \! -d $(SUBDIR) ] && \
-               git clone $(URL) $(SUBDIR) && \
+               git clone $(URL) $(SUBDIR) --recursive && \
                (cd $(SUBDIR) && git checkout $(VERSION)) && \
                echo "Packing checkout..." && \
                rm -rf $(SUBDIR)/.git && \