dropbear: update version to 2015.71
authorFelix Fietkau <nbd@openwrt.org>
Fri, 15 Jan 2016 11:24:09 +0000 (11:24 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 15 Jan 2016 11:24:09 +0000 (11:24 +0000)
Update dropbear to version 2015.71, released on 3 Dec 2015.
Refresh patches.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
SVN-Revision: 48243

package/network/services/dropbear/Makefile
package/network/services/dropbear/patches/120-openwrt_options.patch
package/network/services/dropbear/patches/130-ssh_ignore_o_and_x_args.patch
package/network/services/dropbear/patches/500-set-default-path.patch
package/network/services/dropbear/patches/610-skip-default-keys-in-custom-runs.patch

index ca67ed3c6039957d57d38fbae03b1970db41512a..65a5e79608c840dedc031d6568576c1323b0adab 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
-PKG_VERSION:=2015.68
-PKG_RELEASE:=3
+PKG_VERSION:=2015.71
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://matt.ucc.asn.au/dropbear/releases/ \
        https://dropbear.nl/mirror/releases/
-PKG_MD5SUM:=7664ac10f7cc2301c530eb80c756fc5d
+PKG_MD5SUM:=2ccc0a2f3e37ca221db12c5af6a88137
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
index 87118ef4ba9432435b89584f08a45f605c33b64a..f0202080909e2e8ec553c03f66df20dc7e036216 100644 (file)
@@ -70,7 +70,7 @@
  
  /* The MOTD file path */
  #ifndef MOTD_FILENAME
-@@ -231,7 +231,7 @@ Homedir is prepended unless path begins
+@@ -237,7 +237,7 @@ Homedir is prepended unless path begins
   * note that it will be provided for all "hidden" client-interactive
   * style prompts - if you want something more sophisticated, use 
   * SSH_ASKPASS instead. Comment out this var to remove this functionality.*/
index edb29093aece5423554ccd406e34b41466c25511..bf1641b8bf347d73bf51aacf318e294ade7e1096 100644 (file)
@@ -1,6 +1,6 @@
 --- a/cli-runopts.c
 +++ b/cli-runopts.c
-@@ -315,6 +315,10 @@ void cli_getopts(int argc, char ** argv)
+@@ -284,6 +284,10 @@ void cli_getopts(int argc, char ** argv)
                                        debug_trace = 1;
                                        break;
  #endif
@@ -11,7 +11,7 @@
                                case 'F':
                                case 'e':
  #ifndef ENABLE_USER_ALGO_LIST
-@@ -332,7 +336,6 @@ void cli_getopts(int argc, char ** argv)
+@@ -301,7 +305,6 @@ void cli_getopts(int argc, char ** argv)
                                        print_version();
                                        exit(EXIT_SUCCESS);
                                        break;
index f6880ef77d663d0992e088c64f21e9ad3c93735a..648c391ced95d9ee6245d6e1cb05130e914cee83 100644 (file)
@@ -1,6 +1,6 @@
 --- a/options.h
 +++ b/options.h
-@@ -341,7 +341,7 @@ be overridden at runtime with -I. 0 disa
+@@ -347,7 +347,7 @@ be overridden at runtime with -I. 0 disa
  #define DEFAULT_IDLE_TIMEOUT 0
  
  /* The default path. This will often get replaced by the shell */
index ee6d273344a72a01e8a7b8b69508563dd78ce3a2..f6453a4626ed0bed12d6f60621e2d47362df4510 100644 (file)
@@ -1,6 +1,6 @@
 --- a/svr-runopts.c
 +++ b/svr-runopts.c
-@@ -475,6 +475,7 @@ void load_all_hostkeys() {
+@@ -488,6 +488,7 @@ void load_all_hostkeys() {
                m_free(hostkey_file);
        }
  
@@ -8,7 +8,7 @@
  #ifdef DROPBEAR_RSA
        loadhostkey(RSA_PRIV_FILENAME, 0);
  #endif
-@@ -486,6 +487,7 @@ void load_all_hostkeys() {
+@@ -499,6 +500,7 @@ void load_all_hostkeys() {
  #ifdef DROPBEAR_ECDSA
        loadhostkey(ECDSA_PRIV_FILENAME, 0);
  #endif