gcc: make colors optional based on the GCC_COLORS env var
authorFelix Fietkau <nbd@openwrt.org>
Wed, 25 Nov 2015 14:12:44 +0000 (14:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 25 Nov 2015 14:12:44 +0000 (14:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47642

toolchain/gcc/common.mk

index 0ac7de19f5c4822e76691589e740783610d5e2bc..3e4f3ee984f4f58f9c15c39eb003abb08fa54346 100644 (file)
@@ -151,6 +151,10 @@ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
   GCC_CONFIGURE += --with-mips-plt
 endif
 
+ifndef GCC_VERSION_4_8
+  GCC_CONFIGURE += --with-diagnostics-color=auto-if-env
+endif
+
 ifneq ($(CONFIG_SSP_SUPPORT),)
   GCC_CONFIGURE+= \
                --enable-libssp