kernel: other.mk: add pps-ldisc support
authorStephen Walker <stephendwalker+github@gmail.com>
Wed, 29 Jun 2016 22:34:50 +0000 (18:34 -0400)
committerJohn Crispin <john@phrozen.org>
Thu, 30 Jun 2016 20:48:39 +0000 (22:48 +0200)
The pps-ldisc kernel module supports Pulse-Per-Second connected with the CD (Carrier Detect) pin.

Signed-off-by: Stephen Walker <stephendwalker+github@gmail.com>
package/kernel/linux/modules/other.mk

index 55fd455f0618e3c90ef5c97271f2dadd06c4091b..85f7016673d81086c7aa0b8b459905d6d92e8eea 100644 (file)
@@ -825,6 +825,23 @@ endef
 $(eval $(call KernelPackage,pps-gpio))
 
 
+define KernelPackage/pps-ldisc
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=PPS line discipline
+  DEPENDS:=+kmod-pps
+  KCONFIG:=CONFIG_PPS_CLIENT_LDISC
+  FILES:=$(LINUX_DIR)/drivers/pps/clients/pps-ldisc.ko
+  AUTOLOAD:=$(call AutoLoad,18,pps-ldisc,1)
+endef
+
+define KernelPackage/pps-ldisc/description
+ Support for a PPS source connected with the CD (Carrier
+ Detect) pin of your serial port.
+endef
+
+$(eval $(call KernelPackage,pps-ldisc))
+
+
 define KernelPackage/ptp
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PTP clock support