curl: bump to version 7.54.1
authorAlif M. Ahmad <alive4ever@live.com>
Mon, 26 Jun 2017 15:09:59 +0000 (15:09 +0000)
committerAlexander Couzens <lynxis@fe80.eu>
Fri, 14 Jul 2017 01:10:38 +0000 (03:10 +0200)
Upgrade the curl package to latest version. Patches refreshed.

Signed-off-by: Alif M. Ahmad <alive4ever@live.com>
package/network/utils/curl/Makefile
package/network/utils/curl/patches/200-no_docs_tests.patch
package/network/utils/curl/patches/310-mbedtls-disable-runtime-version-check.patch

index c7361a36bce177aadbdb8f4dbf09e2214715e18a..5d510a4d3926716bc0ac16855a691792b186bb94 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.54.0
+PKG_VERSION:=7.54.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
        http://curl.mirror.anstey.ca/ \
        http://curl.askapache.com/download/ \
        https://curl.haxx.se/download/
-PKG_HASH:=f50ebaf43c507fa7cc32be4b8108fa8bbd0f5022e90794388f3c7694a302ff06
+PKG_HASH:=fdfc4df2d001ee0c44ec071186e770046249263c491fcae48df0e1a3ca8f25a0
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
index 0f7198bc6d0f08ce52e3244045a80cf5a64a0b86..f5a158bf9c2ee76a21c90866b625708f66e67105 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -154,8 +154,8 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
+@@ -154,8 +154,8 @@
  
  bin_SCRIPTS = curl-config
  
@@ -11,7 +11,7 @@
  
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = libcurl.pc
-@@ -272,7 +272,7 @@ cygwinbin:
+@@ -275,7 +275,7 @@
  # We extend the standard install with a custom hook:
  install-data-hook:
        cd include && $(MAKE) install
index 02b7e8d3d8a4dfeb6e2767247b9a654d619a7d45..ef9c4b807064bc9fc9bf26cf3f917b4e6d7e62ee 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/vtls/mbedtls.c
 +++ b/lib/vtls/mbedtls.c
-@@ -791,7 +791,7 @@ void Curl_mbedtls_session_free(void *ptr
+@@ -796,7 +796,7 @@
  
  size_t Curl_mbedtls_version(char *buffer, size_t size)
  {