target.mk: change i386 CPU type to pentium-mmx
authorRosen Penev <rosenp@gmail.com>
Sun, 12 Jan 2020 04:44:34 +0000 (20:44 -0800)
committerPetr Štetiar <ynezz@true.cz>
Wed, 8 Jul 2020 20:54:34 +0000 (22:54 +0200)
f4f8f4a180366ee90fd8e153213db2cb746ca361 broke ffmpeg compilation with x86

The reason is that ffmpeg's x86 assembly requires at least MMX, which the
pentium CPU_TYPE was preventing.

Fixes ffmpeg compilation on x86_legacy and x86_geode.

Ref: https://github.com/openwrt/openwrt/pull/3061
Signed-off-by: Rosen Penev <rosenp@gmail.com>
include/target.mk

index 64292138b7ad1548819bce16c734e1fbbffd1c43..aba477e83b8b00f2d9f2782892fc3b896b173f59 100644 (file)
@@ -174,8 +174,8 @@ ifeq ($(DUMP),1)
     CPU_CFLAGS_octeonplus = -march=octeon+ -mabi=64
   endif
   ifeq ($(ARCH),i386)
-    CPU_TYPE ?= pentium
-    CPU_CFLAGS_pentium = -march=pentium-mmx
+    CPU_TYPE ?= pentium-mmx
+    CPU_CFLAGS_pentium-mmx = -march=pentium-mmx
     CPU_CFLAGS_pentium4 = -march=pentium4
   endif
   ifneq ($(findstring arm,$(ARCH)),)