uboot-mvebu: remove enabled CONFIG_CMD_SETEXPR
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Thu, 28 Apr 2022 13:50:20 +0000 (15:50 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 30 Apr 2022 22:42:30 +0000 (00:42 +0200)
We don't need to make sure that we want to have enabled
CONFIG_CMD_SETEXPR by default, since this is already done in U-boot [1].
This was actually needed only for clearfog board [2], which was added in
commit: da0005a6d08ae33d958a6d8a6c0c12dc07b5b2b8 ("uboot-mvebu: add
patch to enable setexpr for clearfog boards) and send to U-boot to fix
it properly. After a while, there was added support for Turris Omnia,
which uses setexpr as well [3], but for this board, there are no fixes
needed in U-boot and that's why we can remove this option here.

It is helpful with shell scripting. If some downstream distributions are
using it, they should correct it in defconfig for related boards.

[1] https://source.denx.de/u-boot/u-boot/-/blob/e95afa56753cebcd20a5114b6d121f281b789006/cmd/Kconfig#L1504

[2] https://github.com/openwrt/openwrt/blob/852126680e21edc71c0c66561ae5a6d7479dcc67/target/linux/mvebu/image/clearfog.bootscript#L7

[3] https://github.com/openwrt/openwrt/blob/852126680e21edc71c0c66561ae5a6d7479dcc67/target/linux/mvebu/image/turris-omnia.bootscript#L2

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
package/boot/uboot-mvebu/Makefile

index 566f45ffed4282522106e22ac98225b29e9882a9..a154d15dc17c999df5c8759aee2eb78b8be8808e 100644 (file)
@@ -62,13 +62,6 @@ UBOOT_TARGETS:= \
        espressobin \
        uDPU
 
-define Build/Configure
-       # enable additional options beyond <device>_defconfig
-       echo CONFIG_CMD_SETEXPR=y >> $(PKG_BUILD_DIR)/configs/$(UBOOT_CONFIG)_defconfig
-
-       $(call Build/Configure/U-Boot)
-endef
-
 define Package/u-boot/install
        $(if $(findstring cortexa53,$(BUILD_SUBTARGET)),,$(Package/u-boot/install/default))
 endef