kernel: bump 4.19 to 4.19.21
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 13 Feb 2019 10:38:41 +0000 (11:38 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 14 Feb 2019 15:45:01 +0000 (16:45 +0100)
Refreshed all patches.

Remove upstreamed:
- 0007-ARM-dts-Fix-up-the-D-Link-DIR-685-MTD-partition-info.patch

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/apm821xx/patches-4.19/140-GPIO-add-named-gpio-exports.patch
target/linux/cns3xxx/patches-4.19/210-dwc2_defaults.patch
target/linux/gemini/patches-4.19/0007-ARM-dts-Fix-up-the-D-Link-DIR-685-MTD-partition-info.patch [deleted file]
target/linux/generic/hack-4.19/204-module_strip.patch
target/linux/generic/pending-4.19/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch

index 65169af6360fd7083c28149bd9bc8ca448144e14..9dbb7feb360027749e45cd9c08ac040d3e36dc1d 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .134
 LINUX_VERSION-4.9 = .156
 LINUX_VERSION-4.14 = .99
-LINUX_VERSION-4.19 = .20
+LINUX_VERSION-4.19 = .21
 
 LINUX_KERNEL_HASH-3.18.134 = 36bdd04cab3b6c824a4b7e32ae02503f437e0916d5a4ff04c90aa22da2749c2f
 LINUX_KERNEL_HASH-4.9.156 = 5eb1b9ba43370512ab637452089bb93f8c0fdd7d5399e99561d382f74517a816
 LINUX_KERNEL_HASH-4.14.99 = 8ff98caed5b20b733dedcbe99559d71a0e09e239c0c2488b3fd799c96489eb0a
-LINUX_KERNEL_HASH-4.19.20 = dc7d2776dad4bf738e741ed05e7d1bea685855cfb7a62d1706f5f7aeabfa04a4
+LINUX_KERNEL_HASH-4.19.21 = db08ede726fe410da274e1e98f0de2aed9ff4b0e0b63a89e5928bef46998bbc1
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 5a05c6095e9c8043589a7adef0a4ab33525093d4..6b1f7fc1cc093425e35dc73ba93ef63b100db710 100644 (file)
@@ -112,7 +112,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  {
 --- a/include/linux/gpio/consumer.h
 +++ b/include/linux/gpio/consumer.h
-@@ -531,6 +531,7 @@ struct gpio_desc *devm_fwnode_get_gpiod_
+@@ -533,6 +533,7 @@ struct gpio_desc *devm_fwnode_get_gpiod_
  
  #if IS_ENABLED(CONFIG_GPIOLIB) && IS_ENABLED(CONFIG_GPIO_SYSFS)
  
@@ -120,7 +120,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  int gpiod_export(struct gpio_desc *desc, bool direction_may_change);
  int gpiod_export_link(struct device *dev, const char *name,
                      struct gpio_desc *desc);
-@@ -538,6 +539,13 @@ void gpiod_unexport(struct gpio_desc *de
+@@ -540,6 +541,13 @@ void gpiod_unexport(struct gpio_desc *de
  
  #else  /* CONFIG_GPIOLIB && CONFIG_GPIO_SYSFS */
  
index 3e00139aa04c0d54c9855d3c643ca1674ef76fb8..5a5b17d0a087bd6f5f6ebc6702964d11c3318ae1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/dwc2/params.c
 +++ b/drivers/usb/dwc2/params.c
-@@ -144,6 +144,36 @@ static void dwc2_set_stm32f7_hsotg_param
+@@ -151,6 +151,36 @@ static void dwc2_set_stm32f7_hsotg_param
        p->host_perio_tx_fifo_size = 256;
  }
  
@@ -37,7 +37,7 @@
  const struct of_device_id dwc2_of_match_table[] = {
        { .compatible = "brcm,bcm2835-usb", .data = dwc2_set_bcm_params },
        { .compatible = "hisilicon,hi6220-usb", .data = dwc2_set_his_params  },
-@@ -798,17 +828,23 @@ int dwc2_get_hwparams(struct dwc2_hsotg
+@@ -806,17 +836,23 @@ int dwc2_get_hwparams(struct dwc2_hsotg
  
  int dwc2_init_params(struct dwc2_hsotg *hsotg)
  {
diff --git a/target/linux/gemini/patches-4.19/0007-ARM-dts-Fix-up-the-D-Link-DIR-685-MTD-partition-info.patch b/target/linux/gemini/patches-4.19/0007-ARM-dts-Fix-up-the-D-Link-DIR-685-MTD-partition-info.patch
deleted file mode 100644 (file)
index f70ab26..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-From 0f6c4817471faf572b5273cdf90160790b0c3b29 Mon Sep 17 00:00:00 2001
-From: Linus Walleij <linus.walleij@linaro.org>
-Date: Thu, 17 May 2018 17:00:10 +0200
-Subject: [PATCH 07/18] ARM: dts: Fix up the D-Link DIR-685 MTD partition info
-
-The vendor firmware was analyzed to get the right idea about
-this flash layout. /proc/mtd contains:
-
-dev:    size   erasesize  name
-mtd0: 01e7ff40 00020000 "rootfs"
-mtd1: 01f40000 00020000 "upgrade"
-mtd2: 00040000 00020000 "rgdb"
-mtd3: 00020000 00020000 "nvram"
-mtd4: 00040000 00020000 "RedBoot"
-mtd5: 00020000 00020000 "LangPack"
-mtd6: 02000000 00020000 "flash"
-
-Here "flash" is obviously the whole device and we know "rootfs"
-is a bogus hack to point to a squashfs rootfs inside of the main
-"upgrade partition". We know "RedBoot" is the first 0x40000 of
-the flash and the "upgrade" partition follows from 0x40000 to
-0x1f8000. So we have mtd0, 1, 4 and 6 covered.
-
-Remains:
-mtd2: 00040000 00020000 "rgdb"
-mtd3: 00020000 00020000 "nvram"
-mtd5: 00020000 00020000 "LangPack"
-
-Inspecting the flash at 0x1f8000 and 0x1fa000 reveals each of
-these starting with "RGCFG1" so we assume 0x1f8000-1fbfff is
-"rgdb" of 0x40000.
-
-Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
----
- arch/arm/boot/dts/gemini-dlink-dir-685.dts | 16 ++++++----------
- 1 file changed, 6 insertions(+), 10 deletions(-)
-
---- a/arch/arm/boot/dts/gemini-dlink-dir-685.dts
-+++ b/arch/arm/boot/dts/gemini-dlink-dir-685.dts
-@@ -274,20 +274,16 @@
-                               read-only;
-                       };
-                       /*
--                       * Between the boot loader and the rootfs is the kernel
--                       * in a custom Storlink format flashed from the boot
--                       * menu. The rootfs is in squashfs format.
-+                       * This firmware image contains the kernel catenated
-+                       * with the squashfs root filesystem. For some reason
-+                       * this is called "upgrade" on the vendor system.
-                        */
--                      partition@1800c0 {
--                              label = "rootfs";
--                              reg = <0x001800c0 0x01dbff40>;
--                              read-only;
--                      };
--                      partition@1f40000 {
-+                      partition@40000 {
-                               label = "upgrade";
--                              reg = <0x01f40000 0x00040000>;
-+                              reg = <0x00040000 0x01f40000>;
-                               read-only;
-                       };
-+                      /* RGDB, Residental Gateway Database? */
-                       partition@1f80000 {
-                               label = "rgdb";
-                               reg = <0x01f80000 0x00040000>;
index 2630e45b6d75f2d7cec917905764d71cbb372723..7fa5d8ddbc02da96762659fe0c027870a9fd8b8d 100644 (file)
@@ -114,7 +114,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -3002,9 +3002,11 @@ static int setup_load_info(struct load_i
+@@ -3004,9 +3004,11 @@ static int setup_load_info(struct load_i
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -127,7 +127,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (flags & MODULE_INIT_IGNORE_VERMAGIC)
                modmagic = NULL;
  
-@@ -3025,6 +3027,7 @@ static int check_modinfo(struct module *
+@@ -3027,6 +3029,7 @@ static int check_modinfo(struct module *
                                mod->name);
                add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
        }
@@ -137,7 +137,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/scripts/mod/modpost.c
 +++ b/scripts/mod/modpost.c
-@@ -1969,7 +1969,9 @@ static void read_symbols(const char *mod
+@@ -1971,7 +1971,9 @@ static void read_symbols(const char *mod
                symname = remove_dot(info.strtab + sym->st_name);
  
                handle_modversions(mod, &info, sym, symname);
@@ -147,7 +147,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        }
        if (!is_vmlinux(modname) || vmlinux_section_warnings)
                check_sec_ref(mod, modname, &info);
-@@ -2132,8 +2134,10 @@ static void add_header(struct buffer *b,
+@@ -2134,8 +2136,10 @@ static void add_header(struct buffer *b,
        buf_printf(b, "\n");
        buf_printf(b, "BUILD_SALT;\n");
        buf_printf(b, "\n");
@@ -158,7 +158,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        buf_printf(b, "\n");
        buf_printf(b, "__visible struct module __this_module\n");
        buf_printf(b, "__attribute__((section(\".gnu.linkonce.this_module\"))) = {\n");
-@@ -2150,8 +2154,10 @@ static void add_header(struct buffer *b,
+@@ -2152,8 +2156,10 @@ static void add_header(struct buffer *b,
  
  static void add_intree_flag(struct buffer *b, int is_intree)
  {
@@ -169,7 +169,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
  
  /* Cannot check for assembler */
-@@ -2164,8 +2170,10 @@ static void add_retpoline(struct buffer
+@@ -2166,8 +2172,10 @@ static void add_retpoline(struct buffer
  
  static void add_staging_flag(struct buffer *b, const char *name)
  {
@@ -180,7 +180,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
  
  /**
-@@ -2264,11 +2272,13 @@ static void add_depends(struct buffer *b
+@@ -2266,11 +2274,13 @@ static void add_depends(struct buffer *b
  
  static void add_srcversion(struct buffer *b, struct module *mod)
  {
@@ -194,7 +194,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
  
  static void write_if_changed(struct buffer *b, const char *fname)
-@@ -2505,7 +2515,9 @@ int main(int argc, char **argv)
+@@ -2507,7 +2517,9 @@ int main(int argc, char **argv)
                add_staging_flag(&buf, mod->name);
                err |= add_versions(&buf, mod);
                add_depends(&buf, mod, modules);
index 869af0e6496b3b8a9f8a67d99a2ba5f6421c7ca3..3aca45766087d94666499b7b25241341d5bc8421 100644 (file)
@@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
 
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -6372,7 +6372,7 @@ static void __ref alloc_node_mem_map(str
+@@ -6393,7 +6393,7 @@ static void __ref alloc_node_mem_map(str
                mem_map = NODE_DATA(0)->node_mem_map;
  #if defined(CONFIG_HAVE_MEMBLOCK_NODE_MAP) || defined(CONFIG_FLATMEM)
                if (page_to_pfn(mem_map) != pgdat->node_start_pfn)