Revert "kernel: remove all local symbols from kernel modules at link time to reduce...
authorFelix Fietkau <nbd@openwrt.org>
Sat, 26 Mar 2011 15:29:53 +0000 (15:29 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 26 Mar 2011 15:29:53 +0000 (15:29 +0000)
SVN-Revision: 26305

rules.mk
target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch [deleted file]
target/linux/generic/patches-2.6.37/950-powerpc_crtsavres_prereq.patch
target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch [deleted file]
target/linux/generic/patches-2.6.38/950-powerpc_crtsavres_prereq.patch

index cddfdf5d308d9040c5d364fc6140ca5709759565..428258f5f4af8dca9a4f91b284be15ee2e642459 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -211,7 +211,7 @@ else
   RSTRIP:= \
     NM="$(TARGET_CROSS)nm" \
     STRIP="$(STRIP)" \
-    STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded -R .comment -R .pdr -R .mdebug.abi32 -R .note.gnu.build-id -R .gnu.attributes -R .reginfo" \
+    STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded -R .comment -R .pdr -R .mdebug.abi32 -R .note.gnu.build-id -R .gnu.attributes -R .reginfo -x" \
     $(SCRIPT_DIR)/rstrip.sh
 endif
 
diff --git a/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch b/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch
deleted file mode 100644 (file)
index 2e25081..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -360,7 +360,7 @@
- KBUILD_AFLAGS   := -D__ASSEMBLY__
- KBUILD_AFLAGS_MODULE  := -DMODULE
- KBUILD_CFLAGS_MODULE  := -DMODULE
--KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
-+KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
- # Read KERNELRELEASE from include/config/kernel.release (if it exists)
- KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
index 47f796a909ff4af0f938fa519059ed9808df46cb..861a6b7538d5ca84ec4f66fd5ae362e29b91ad9b 100644 (file)
@@ -3,7 +3,7 @@
 @@ -361,6 +361,7 @@ KBUILD_AFLAGS   := -D__ASSEMBLY__
  KBUILD_AFLAGS_MODULE  := -DMODULE
  KBUILD_CFLAGS_MODULE  := -DMODULE
- KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
+ KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
 +KBUILD_LDFLAGS_MODULE_PREREQ  := 
  
  # Read KERNELRELEASE from include/config/kernel.release (if it exists)
diff --git a/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch b/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch
deleted file mode 100644 (file)
index 86a3e2f..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -361,7 +361,7 @@
- KBUILD_AFLAGS   := -D__ASSEMBLY__
- KBUILD_AFLAGS_MODULE  := -DMODULE
- KBUILD_CFLAGS_MODULE  := -DMODULE
--KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
-+KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
- # Read KERNELRELEASE from include/config/kernel.release (if it exists)
- KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
index 2d3a67d12b5e2121df5ce26ffc5625b27fe832d5..402cd0cacb2e30c36496f4db606b93f4064ef929 100644 (file)
@@ -3,7 +3,7 @@
 @@ -362,6 +362,7 @@ KBUILD_AFLAGS   := -D__ASSEMBLY__
  KBUILD_AFLAGS_MODULE  := -DMODULE
  KBUILD_CFLAGS_MODULE  := -DMODULE
- KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
+ KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
 +KBUILD_LDFLAGS_MODULE_PREREQ  := 
  
  # Read KERNELRELEASE from include/config/kernel.release (if it exists)