ar71xx: create images for the WNDR3700, which can be flashed via the factory web...
authorGabor Juhos <juhosg@openwrt.org>
Sat, 28 Nov 2009 09:28:25 +0000 (09:28 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 28 Nov 2009 09:28:25 +0000 (09:28 +0000)
SVN-Revision: 18571

target/linux/ar71xx/image/Makefile
tools/firmware-utils/Makefile
tools/firmware-utils/src/mkdniimg.c [new file with mode: 0644]

index 4c88a85e645f06ceef52a0035226b4a4a57f285d..04629ffd54e2071e6bc2e25fe28dd61c3d3eea4b 100644 (file)
@@ -241,6 +241,10 @@ define Image/Build/WNDR3700
                dd if=$(KDIR)/vmlinux-$(2).uImage.squashfs bs=1M conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k; \
        ) > $(call imgname,$(1),$(2))-sysupgrade.bin
+       $(STAGING_DIR_HOST)/bin/mkdniimg \
+               -B WNDR3700 -v OpenWrt.$(REVISION) \
+               -i $(call imgname,$(1),$(2))-sysupgrade.bin \
+               -o $(call imgname,$(1),$(2))-factory.bin
 endef
 
 define Image/Build/Template/Compex
index ec41e08273766ce4407523d7243c570dc173959b..85ef59509ea33a2d9555f804c3e12c584d494569 100644 (file)
@@ -53,6 +53,7 @@ define Host/Compile
        $(call cc,osbridge-crc)
        $(call cc2,wrt400n cyg_crc32)
        $(call cc,wndr3700)
+       $(call cc,mkdniimg)
 endef
 
 define Host/Install
diff --git a/tools/firmware-utils/src/mkdniimg.c b/tools/firmware-utils/src/mkdniimg.c
new file mode 100644 (file)
index 0000000..31b3210
--- /dev/null
@@ -0,0 +1,199 @@
+/*
+ *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ *
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <stdint.h>
+#include <string.h>
+#include <unistd.h>     /* for unlink() */
+#include <libgen.h>
+#include <getopt.h>     /* for getopt() */
+#include <stdarg.h>
+#include <errno.h>
+#include <sys/stat.h>
+
+#define DNI_HDR_LEN    128
+
+/*
+ * Globals
+ */
+static char *ifname;
+static char *progname;
+static char *ofname;
+static char *version = "1.00.00";
+static char *region ="NA";
+
+static char *board_id;
+/*
+ * Message macros
+ */
+#define ERR(fmt, ...) do { \
+       fflush(0); \
+       fprintf(stderr, "[%s] *** error: " fmt "\n", \
+                       progname, ## __VA_ARGS__ ); \
+} while (0)
+
+#define ERRS(fmt, ...) do { \
+       int save = errno; \
+       fflush(0); \
+       fprintf(stderr, "[%s] *** error: " fmt "\n", \
+                       progname, ## __VA_ARGS__, strerror(save)); \
+} while (0)
+
+void usage(int status)
+{
+       FILE *stream = (status != EXIT_SUCCESS) ? stderr : stdout;
+       struct board_info *board;
+
+       fprintf(stream, "Usage: %s [OPTIONS...]\n", progname);
+       fprintf(stream,
+"\n"
+"Options:\n"
+"  -B <board>      create image for the board specified with <board>\n"
+"  -i <file>       read input from the file <file>\n"
+"  -o <file>       write output to the file <file>\n"
+"  -v <version>    set image version to <version>\n"
+"  -r <region>     set image region to <region>\n"
+"  -h              show this screen\n"
+       );
+
+       exit(status);
+}
+
+int main(int argc, char *argv[])
+{
+       int res = EXIT_FAILURE;
+       int buflen;
+       int err;
+       struct stat st;
+       char *buf;
+       int i;
+       uint8_t csum;
+
+       FILE *outfile, *infile;
+
+       progname = basename(argv[0]);
+
+       while ( 1 ) {
+               int c;
+
+               c = getopt(argc, argv, "B:i:o:v:r:h");
+               if (c == -1)
+                       break;
+
+               switch (c) {
+               case 'B':
+                       board_id = optarg;
+                       break;
+               case 'i':
+                       ifname = optarg;
+                       break;
+               case 'o':
+                       ofname = optarg;
+                       break;
+               case 'v':
+                       version = optarg;
+                       break;
+               case 'r':
+                       region = optarg;
+                       break;
+               case 'h':
+                       usage(EXIT_SUCCESS);
+                       break;
+               default:
+                       usage(EXIT_FAILURE);
+                       break;
+               }
+       }
+
+       if (board_id == NULL) {
+               ERR("no board specified");
+               goto err;
+       }
+
+       if (ifname == NULL) {
+               ERR("no input file specified");
+               goto err;
+       }
+
+       if (ofname == NULL) {
+               ERR("no output file specified");
+               goto err;
+       }
+
+       err = stat(ifname, &st);
+       if (err){
+               ERRS("stat failed on %s", ifname);
+               goto err;
+       }
+
+       buflen = st.st_size + DNI_HDR_LEN + 1;
+       buf = malloc(buflen);
+       if (!buf) {
+               ERR("no memory for buffer\n");
+               goto err;
+       }
+
+       memset(buf, 0, DNI_HDR_LEN);
+       snprintf(buf, DNI_HDR_LEN, "device:%s\nversion:V%s\nregion:%s\n",
+                board_id, version, region);
+
+       infile = fopen(ifname, "r");
+       if (infile == NULL) {
+               ERRS("could not open \"%s\" for reading", ifname);
+               goto err_free;
+       }
+
+       errno = 0;
+       fread(buf +  DNI_HDR_LEN, st.st_size, 1, infile);
+       if (errno != 0) {
+               ERRS("unable to read from file %s", ifname);
+               goto err_close_in;
+       }
+
+       csum = 0;
+       for (i = 0; i < (st.st_size + DNI_HDR_LEN); i++)
+               csum += buf[i];
+
+       csum = 0xff - csum;
+       buf[st.st_size + DNI_HDR_LEN] = csum;
+
+       outfile = fopen(ofname, "w");
+       if (outfile == NULL) {
+               ERRS("could not open \"%s\" for writing", ofname);
+               goto err_close_in;
+       }
+
+       errno = 0;
+       fwrite(buf, buflen, 1, outfile);
+       if (errno) {
+               ERRS("unable to write to file %s", ofname);
+               goto err_close_out;
+       }
+
+       res = EXIT_SUCCESS;
+
+ out_flush:
+       fflush(outfile);
+
+ err_close_out:
+       fclose(outfile);
+       if (res != EXIT_SUCCESS) {
+               unlink(ofname);
+       }
+
+ err_close_in:
+       fclose(infile);
+
+ err_free:
+       free(buf);
+
+ err:
+       return res;
+}