bugfix
authorMike Baker <mbm@openwrt.org>
Sat, 26 Feb 2005 02:32:16 +0000 (02:32 +0000)
committerMike Baker <mbm@openwrt.org>
Sat, 26 Feb 2005 02:32:16 +0000 (02:32 +0000)
SVN-Revision: 294

openwrt/Makefile
openwrt/package/openwrt/jffs2root.c
openwrt/target/default/target_skeleton/etc/preinit
openwrt/target/squashfs-lzma/squashfslzmaroot.mk
openwrt/target/squashfs/squashfsroot.mk

index dfa272120bb2a02061c30ae82f7cfdd38792ada1..b8c9b10b7068b644538aeaa550fa85cbe49f4e36 100644 (file)
@@ -118,6 +118,8 @@ $(TARGET_DIR):
        fi;
        -find $(TARGET_DIR) -type d -name CVS | xargs rm -rf
        -find $(TARGET_DIR) -type d -name .svn | xargs rm -rf
+       -ln -sf /tmp/resolv.conf $(TARGET_DIR)
+       -mkdir -p $(TARGET_DIR)/jffs
 
 source: $(TARGETS_SOURCE)
 
index e74c89a9ba88c5cda3d6d5c68268eba21d58312d..2ff37fdad3b99973a0617158bbf32f981f46c0d8 100644 (file)
@@ -48,7 +48,10 @@ void init_crc32()
     unsigned long crc;
     unsigned long poly = 0xEDB88320L;
     int n, bit;
-    crc32 = (unsigned long *) malloc(256 * sizeof(unsigned long));
+    if ((crc32 = (unsigned long *) malloc(256 * sizeof(unsigned long))) == (void *)-1) {
+           perror("malloc");
+           exit(1);
+    }
     for (n = 0; n < 256; n++) {
        crc = (unsigned long) n;
        for (bit = 0; bit < 8; bit++)
index d2036f4e5925d9e4209c33f5aee470dd15c252f8..28fe8052609764a339ac7b0cfee9284e4cc837f1 100755 (executable)
@@ -11,10 +11,10 @@ else
     mtd unlock mtd4
     mount -t jffs2 /dev/mtdblock/4 /jffs
     pivot_root /jffs /jffs/rom
-    mount none /dev -t devfs
-    mount none /proc -t proc
-    umount rom/proc
   }
+  mount none /dev -t devfs
+  mount none /proc -t proc
+  umount rom/proc
 fi
 mount none /tmp -t ramfs
 exec /sbin/init
index 4059896bc9e1c11cbe3bb66629057204f836c3f3..722c20524e711036a3b76e2c2f9c822e70ed9200 100644 (file)
@@ -39,7 +39,6 @@ squashfslzma-dirclean:
 squashfslzmaroot: squashfslzma
        @rm -rf $(TARGET_DIR)/usr/man
        @rm -rf $(TARGET_DIR)/usr/info
-       @mkdir -p $(TARGET_DIR)/jffs
        $(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma $(TARGET_DIR) $(IMAGE).squashfslzma -noappend -root-owned -le
 
 squashfslzmaroot-source: squashfslzma-source
index 62b645a883669e9f27b220da8617aae9a1f71923..d3a104a83f3e6f0ed8e4ed4f95cbb72c5fe04de5 100644 (file)
@@ -38,7 +38,6 @@ squashfs-dirclean:
 squashfsroot: squashfs
        @rm -rf $(TARGET_DIR)/usr/man
        @rm -rf $(TARGET_DIR)/usr/info
-       @mkdir -p $(TARGET_DIR)/jffs
        $(SQUASHFS_DIR)/squashfs-tools/mksquashfs $(TARGET_DIR) $(IMAGE).squashfs -noappend -root-owned -le
 
 squashfsroot-source: squashfs-source