libnl-tiny: honor CFLAGS when linking
authorSteven Barth <cyrus@openwrt.org>
Thu, 18 Jun 2015 08:13:04 +0000 (08:13 +0000)
committerSteven Barth <cyrus@openwrt.org>
Thu, 18 Jun 2015 08:13:04 +0000 (08:13 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 46029

package/libs/libnl-tiny/Makefile
package/libs/libnl-tiny/src/Makefile

index 2445ad440b0d03463f416e633ea2dd6032c52ad3..33a47582526de2dd550b97e726e9a9accc1b6935 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnl-tiny
 PKG_VERSION:=0.1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_LICENSE:=LGPL-2.1
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
index 4d090b35eca1216ebbfe2aea0823c0c66a206ebe..6f37160a8c35ae63383801ed67936e5175d15b7c 100644 (file)
@@ -14,4 +14,4 @@ LIBNL_OBJ=nl.o handlers.o msg.o attr.o cache.o cache_mngt.o object.o socket.o er
 GENL_OBJ=genl.o genl_family.o genl_ctrl.o genl_mngt.o unl.o
 
 $(LIBNAME): $(LIBNL_OBJ) $(GENL_OBJ)
-       $(CC) -Wl,-Bsymbolic-functions -shared -o $@ $^
+       $(CC) $(CFLAGS) -Wl,-Bsymbolic-functions -shared -o $@ $^