linux/modules: Add SCH5627 Super I/O chips
authorLucian Cristian <lucian.cristian@gmail.com>
Sun, 31 Jul 2016 12:42:53 +0000 (15:42 +0300)
committerJohn Crispin <john@phrozen.org>
Wed, 3 Aug 2016 13:30:13 +0000 (15:30 +0200)
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
package/kernel/linux/modules/hwmon.mk

index f7a92eda1ed940ce317a2adcf6b7ea956d079d11..0a8115c28b3b3a7fe12856bab749484d6f66cc0d 100644 (file)
@@ -252,6 +252,22 @@ endef
 
 $(eval $(call KernelPackage,hwmon-sht21))
 
+define KernelPackage/hwmon-sch5627
+  TITLE:=SMSC SCH5627 monitoring support
+  KCONFIG:=CONFIG_SENSORS_SCH5627
+  FILES:= \
+       $(LINUX_DIR)/drivers/hwmon/sch5627.ko \
+       $(LINUX_DIR)/drivers/hwmon/sch56xx-common.ko
+  AUTOLOAD:=$(call AutoProbe,sch5627)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-sch5627/description
+ SMSC SCH5627 Super I/O chips include complete hardware monitoring
+endef
+
+$(eval $(call KernelPackage,hwmon-sch5627))
+
 define KernelPackage/hwmon-pc87360
   TITLE:=PC87360 monitoring support
   KCONFIG:=CONFIG_SENSORS_PC87360