firewall: properly dispatch delif events if the network has a different name then...
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 14 Sep 2009 14:47:43 +0000 (14:47 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 14 Sep 2009 14:47:43 +0000 (14:47 +0000)
SVN-Revision: 17580

package/firewall/Makefile
package/firewall/files/20-firewall

index 40bbe300b0dde1030e3fde637771c7ab0e659558..2e236fe719773fd2c26512def686aa7459e73792 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=1
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 include $(INCLUDE_DIR)/package.mk
 
index 38fbb9441877cf930c3188e467368785cde7afa5..32f8a853da727f8c072ba8942bdfd047caca3e54 100644 (file)
@@ -29,7 +29,7 @@ config_foreach load_zones zone
 [ ifdown = "$ACTION" ] && {
        for z in $ZONE; do 
                local up
-               config_get up $z up
+               config_get up "$INTERFACE" up
                [ "$up" == "1" ] && delif "$INTERFACE" "$ifname" "$z"
        done
 }