ramips: add support for Telco Electronics X1
authorNicholas Smith <mips171@icloud.com>
Fri, 19 Apr 2019 04:12:11 +0000 (14:12 +1000)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 18 May 2019 15:59:49 +0000 (17:59 +0200)
Hardware:
SoC:   MT7621
DRAM:  256MB DDR3
Flash: 16MB SPI-NOR
WiFi:  2.4GHz: MT7603 @ PCIe0
WiFi:  5.8GHz: MT7612 @ PCIe1
Modem: Sierra Wireless MC74xx

Interfaces:
GBE RJ45 x5
mPCIe    x2
UART     x1
I2C      x1
JTAG     x1
UIM      x1
LEDs     x6

Flash instructions:
Flash from within the factory bootloader, firmware web interface or CLI using
sysupgrade -F -n

Signed-off-by: Nicholas Smith <mips171@icloud.com>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/board.d/03_gpio_switches
target/linux/ramips/dts/Telco-Electronics-X1.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk

index 9c9517a7f3f956959f92e53c4ae117494e9b9f61..dcc7b4a74708d6cfe75591baa4671d6c46bf10ca 100755 (executable)
@@ -119,6 +119,7 @@ ramips_setup_interfaces()
        rt-n12p|\
        sap-g3200u3|\
        sk-wb8|\
+       telco-electronics,x1|\
        unielec,u7621-06-256m-16m|\
        unielec,u7621-06-512m-64m|\
        vr500|\
index 8abe107a7c724fb1236b6c95fa3611146f23eb40..1406f91f8f74ea2724125a588c370318a045f666 100755 (executable)
@@ -22,6 +22,9 @@ head-weblink,hdrm200)
 mikrotik,rb750gr3)
        ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "17"
        ;;
+telco-electronics,x1)
+       ucidef_add_gpio_switch "modem_reset" "Modem Reset" "16"
+       ;;
 ubnt-erx)
        ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "0"
        ;;
diff --git a/target/linux/ramips/dts/Telco-Electronics-X1.dts b/target/linux/ramips/dts/Telco-Electronics-X1.dts
new file mode 100644 (file)
index 0000000..33fc181
--- /dev/null
@@ -0,0 +1,172 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "telco-electronics,x1", "mediatek,mt7621-soc";
+       model = "Telco Electronics X1";
+
+       aliases {
+               led-boot = &system_led;
+               led-failsafe = &system_led;
+               led-running = &system_led;
+               led-upgrade = &system_led;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               system_led: system {
+                       label = "x1:green:system";
+                       gpios = <&gpio0 26 GPIO_ACTIVE_LOW>;
+               };
+
+               modem_offline {
+                       label = "x1:red:modem-offline";
+                       gpios = <&gpio0 23 GPIO_ACTIVE_HIGH>;
+               };
+
+               modem_4g {
+                       label = "x1:blue:modem-4g";
+                       gpios = <&gpio0 24 GPIO_ACTIVE_LOW>;
+               };
+
+               modem_3g {
+                       label = "x1:green:modem-3g";
+                       gpios = <&gpio0 25 GPIO_ACTIVE_LOW>;
+               };
+
+               modem_rssi_lowest {
+                       label = "x1:green:modem-rssi-lowest";
+                       gpios = <&gpio0 27 GPIO_ACTIVE_LOW>;
+               };
+
+               modem_rssi_low {
+                       label = "x1:green:modem-rssi-low";
+                       gpios = <&gpio0 28 GPIO_ACTIVE_LOW>;
+               };
+
+               modem_rssi_medium {
+                       label = "x1:green:modem-rssi-medium";
+                       gpios = <&gpio0 29 GPIO_ACTIVE_LOW>;
+               };
+
+               modem_rssi_high {
+                       label = "x1:green:modem-rssi-high";
+                       gpios = <&gpio0 30 GPIO_ACTIVE_LOW>;
+               };
+
+               modem_rssi_highest {
+                       label = "x1:green:modem-rssi-highest";
+                       gpios = <&gpio0 31 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x10000000>;
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <14000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "bootloader";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "config";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       firmware: partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x50000 0xfb0000>;
+                       };
+               };
+       };
+};
+
+&gpio0 {
+       status = "okay";
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0xe006>;
+       mediatek,portmap = "llllw";
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "jtag", "uart2", "wdt", "rgmii2";
+                       ralink,function = "gpio";
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+
+       pcie0 {
+               wifi@0,0 {
+                       compatible = "pci14c3,7603";
+                       reg = <0x0000 0 0 0 0>;
+                       mediatek,mtd-eeprom = <&factory 0x0000>;
+                       ieee80211-freq-limit = <2400000 2500000>;
+               };
+       };
+
+       pcie1 {
+               wifi@0,0 {
+                       compatible = "pci14c3,7662";
+                       reg = <0x0000 0 0 0 0>;
+                       mediatek,mtd-eeprom = <&factory 0x8000>;
+                       ieee80211-freq-limit = <5000000 6000000>;
+                       led {
+                               led-sources = <2>;
+                       };
+               };
+       };
+};
index 671e7f378af42465be44fa73848f8cc11462359f..c21b9b4b63adf4ee44b3b983439d2ccb5b33cad3 100644 (file)
@@ -435,6 +435,14 @@ define Device/sk-wb8
 endef
 TARGET_DEVICES += sk-wb8
 
+define Device/telco-electronics_x1
+  DTS := Telco-Electronics-X1
+  IMAGE_SIZE := 16064k
+  DEVICE_TITLE := Telco Electronics X1
+  DEVICE_PACKAGES := kmod-usb3 kmod-mt76 wpad-basic
+endef
+TARGET_DEVICES += telco-electronics_x1
+
 define Device/timecloud
   DTS := Timecloud
   DEVICE_TITLE := Thunder Timecloud