powerpc: Create a powerpc64 config feature
authorGeoff Levand <geoffrey.levand@am.sony.com>
Tue, 18 Aug 2009 23:07:45 +0000 (23:07 +0000)
committerGeoff Levand <geoffrey.levand@am.sony.com>
Tue, 18 Aug 2009 23:07:45 +0000 (23:07 +0000)
The config symbol TARGET_ps3 is used in the build files where
special handling for the 64 bit PowerPC processors is needed.
Introduce a new config feature powerpc64, and replace the use
of TARGET_ps3 with powerpc64.

Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com>
SVN-Revision: 17306

package/kexec-tools/Makefile
package/kexec-tools/kexec-config.in
scripts/metadata.pl
target/Config.in
target/linux/ps3/Makefile
target/linux/ps3/petitboot/target.mk
toolchain/Config.in
toolchain/gcc/Config.in
toolchain/gcc/Config.version

index 3f6137d3daca952694a515444614b318ddc30eae..81ae9d37cd0d61ad29c856d32094a0f4cc466fb3 100644 (file)
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/kexec-tools
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@armeb||@i386||@TARGET_ps3||@mipsel||@mips +zlib
+  DEPENDS:=@armeb||@i386||@powerpc64||@mipsel||@mips +zlib
   TITLE:=Kernel boots kernel
   URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
   MENU:=1
index 0910ac202ea753b01fe24548cf9a1ae53064701a..7aa3f1db2e85c30567ae1dbc03b8f8106b03b7b3 100644 (file)
@@ -2,7 +2,7 @@
 config KEXEC_TOOLS_TARGET_NAME
        string
        prompt "Target name for kexec kernel" if PACKAGE_kexec-tools
-       default EXTRA_TARGET_ARCH_NAME  if TARGET_ps3
+       default EXTRA_TARGET_ARCH_NAME  if powerpc64
        default ARCH
        help
          Defines the target type of the kernels that kexec deals
index e8850c937f94f884353ba6f7a5c7b77cdfe986f1..39304dfbe79c328968ce4d95085c7454fcf1df25 100755 (executable)
@@ -165,6 +165,7 @@ sub target_config_features(@) {
                /cpiogz/ and $ret .= "\tselect USES_CPIOGZ\n";
                /fpu/ and $ret .= "\tselect HAS_FPU\n";
                /ramdisk/ and $ret .= "\tselect USES_INITRAMFS\n";
+               /powerpc64/ and $ret .= "\tselect powerpc64\n";
        }
        return $ret;
 }
index 8bfeb83b27722e6f2ad4cf21b00dec60ac383d37..ffd81d3f6c8ee86ef8b85ade32fc993dfcec4c2a 100644 (file)
@@ -100,6 +100,9 @@ config powerpc
        select BIG_ENDIAN
        bool
 
+config powerpc64
+       bool
+
 config sh3
        bool
 
index 64d8477199ae8c0b6c869be6d8893e166931f714..b59e161582019f6500ca3b0b5a28150e0ec9cbc4 100644 (file)
@@ -11,6 +11,7 @@ BOARD:=ps3
 BOARDNAME:=Sony PS3 Game Console
 MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
 SUBTARGETS=petitboot
+FEATURES+=powerpc64
 
 LINUX_VERSION:=2.6.28.10
 
index 04ec11bb3e2d1a54b27765e34b49bf3d3870d471..845c4316d3cc4059cefc50425e2b5693c692e131 100644 (file)
@@ -1,5 +1,5 @@
 BOARDNAME:=Petitboot
-FEATURES:=fpu ramdisk
+FEATURES+=fpu ramdisk
 
 define Target/Description
        Build Petitboot bootloader
index 6fc7b6fcecb473ec0807e60768de09a1052a2c42..f01b6c23b20c9fb4de4c49c65e35410e0d48d987 100644 (file)
@@ -13,7 +13,7 @@ menuconfig TOOLCHAINOPTS
 menuconfig EXTRA_TARGET_ARCH
        bool
        prompt "Enable an extra toolchain target architecture" if TOOLCHAINOPTS
-       default y       if TARGET_ps3 || TARGET_pxcab
+       default y       if powerpc64 || TARGET_pxcab
        default n
        help
          Some builds may require a 'biarch' toolchain. This option
@@ -23,7 +23,7 @@ menuconfig EXTRA_TARGET_ARCH
 
        config EXTRA_TARGET_ARCH_NAME
                string
-               default "powerpc64"     if TARGET_ps3 || TARGET_pxcab
+               default "powerpc64"     if powerpc64 || TARGET_pxcab
                prompt "Extra architecture name" if EXTRA_TARGET_ARCH
                help
                  Specify the cpu name (eg powerpc64 or x86_64) of the
@@ -31,7 +31,7 @@ menuconfig EXTRA_TARGET_ARCH
 
        config EXTRA_TARGET_ARCH_OPTS
                string
-               default "-m64"          if TARGET_ps3 || TARGET_pxcab
+               default "-m64"          if powerpc64 || TARGET_pxcab
                prompt "Extra architecture compiler options" if EXTRA_TARGET_ARCH
                help
                  If you're specifying an addition target architecture,
index 41943c8cc8733abc06bac62459bd1d05232b8972..6cbf2cdb630a7599b8f7f145519da33bbf55a03c 100644 (file)
@@ -6,7 +6,7 @@ choice
        default GCC_VERSION_4_2_4 if TARGET_avr32
        default GCC_VERSION_4_2_4 if TARGET_ppc40x
        default GCC_VERSION_4_2_4 if TARGET_ppc44x
-       default GCC_VERSION_4_3_3 if TARGET_ps3_petitboot
+       default GCC_VERSION_4_3_3 if powerpc64
        default GCC_VERSION_4_3_3 if TARGET_pxcab
        default GCC_VERSION_4_3_3 if TARGET_etrax
        default GCC_VERSION_4_3_3 if TARGET_coldfire
index 53688c217a40b2b047c7e686045717505f9d55fd..5a0f66887023f2ddbab4859deb3445c0af3d022c 100644 (file)
@@ -52,7 +52,7 @@ if !TOOLCHAINOPTS
                default y if TARGET_ppc44x
 
        config GCC_VERSION_4_3_3
-               default y if TARGET_ps3_petitboot
+               default y if powerpc64
                default y if TARGET_pxcab
                default y if TARGET_etrax
                default y if TARGET_coldfire