prepare libtool for being build nativly (and therefore being able to build libtool...
authorMirko Vogt <mirko@openwrt.org>
Mon, 20 Apr 2009 17:57:24 +0000 (17:57 +0000)
committerMirko Vogt <mirko@openwrt.org>
Mon, 20 Apr 2009 17:57:24 +0000 (17:57 +0000)
SVN-Revision: 15298

package/libtool/Makefile

index 324025a295b607b0cd3d8dad8a0652c5b90c0c90..699e537cb391131c7a0e3641cbe7f2161f185762 100644 (file)
@@ -17,6 +17,9 @@ PKG_MD5SUM:=d0071c890101fcf4f2be8934a37841b0
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
+HOST_PATCH_DIR=/dev/null
+
+include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 
 CONFIGURE_PREFIX=$(STAGING_DIR)/host
@@ -39,8 +42,6 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include
        mv $(2)/lib/* $(1)/usr/lib/
        mv $(2)/include/* $(1)/usr/include/
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
-       $(CP) $(2)/share/aclocal/* $(STAGING_DIR_HOST)/share/aclocal/
        $(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(2)/bin/libtool
 endef
 
@@ -49,4 +50,5 @@ define Package/libltdl/install
        $(CP) $(PKG_BUILD_DIR)/libltdl/.libs/libltdl.so.* $(1)/usr/lib/
 endef
 
+$(eval $(call HostBuild))
 $(eval $(call BuildPackage,libltdl))