map: add ealen as configurable uci parameter
authorHans Dedecker <dedeckeh@gmail.com>
Thu, 24 Aug 2017 18:53:36 +0000 (20:53 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Thu, 24 Aug 2017 18:56:07 +0000 (20:56 +0200)
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/ipv6/map/Makefile
package/network/ipv6/map/files/map.sh

index fd8291d683853d0f6695552e192af7f20e0e7fa5..203e6dc5095448082f1ee44faa14b5feac3a13fe 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=map
 PKG_VERSION:=4
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index fe872828c3b95344689663c339effe4b07ad0564..e0dc034ce98dbcea62ccdce701a8ac8e58fed3fe 100755 (executable)
@@ -216,6 +216,7 @@ proto_map_init_config() {
        proto_config_add_string "ip6prefix"
        proto_config_add_int "ip6prefixlen"
        proto_config_add_string "peeraddr"
+       proto_config_add_int "ealen"
        proto_config_add_int "psidlen"
        proto_config_add_int "psid"
        proto_config_add_int "offset"