imx6: remove kmod-thermal-imx, it is already enabled in the kernel config
authorFelix Fietkau <nbd@nbd.name>
Tue, 10 Jan 2017 09:02:36 +0000 (10:02 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 10 Jan 2017 11:10:20 +0000 (12:10 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/linux/modules/other.mk
target/linux/imx6/image/Makefile
target/linux/imx6/profiles/100-generic.mk

index 30d145d7f21c01f5fb17c2d398dc27cae80b4f62..982178064156dfdacc60e2cedbc484b780981f1d 100644 (file)
@@ -890,26 +890,6 @@ endef
 $(eval $(call KernelPackage,thermal))
 
 
-define KernelPackage/thermal-imx
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Temperature sensor driver for Freescale i.MX SoCs
-  DEPENDS:=@TARGET_imx6 +kmod-thermal
-  KCONFIG:= \
-       CONFIG_IMX_THERMAL
-  FILES:=$(LINUX_DIR)/drivers/thermal/imx_thermal.ko
-  AUTOLOAD:=$(call AutoProbe,imx_thermal)
-endef
-
-define KernelPackage/thermal-imx/description
- Support for Temperature Monitor (TEMPMON) found on Freescale i.MX SoCs.
- It supports one critical trip point and one passive trip point. The
- cpufreq is used as the cooling device to throttle CPUs when the
- passive trip is crossed.
-endef
-
-$(eval $(call KernelPackage,thermal-imx))
-
-
 define KernelPackage/gpio-beeper
   SUBMENU:=$(OTHER_MENU)
   TITLE:=GPIO beeper support
index 2e4763ea651c24ce64718c17b03b0482977a5bca..7407db8037596cd8c37ae2e49d50fb24e969aa34 100644 (file)
@@ -86,7 +86,7 @@ define Device/ventana
        imx6q-gw551x \
        imx6q-gw552x \
        imx6q-gw553x
-  DEVICE_PACKAGES := kmod-thermal-imx kmod-sky2 kmod-usb-chipidea-imx kmod-usb-mxs-phy \
+  DEVICE_PACKAGES := kmod-sky2 kmod-usb-chipidea-imx kmod-usb-mxs-phy \
        kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
        kmod-can kmod-can-flexcan kmod-can-raw \
        kmod-hwmon-gsc \
@@ -116,7 +116,7 @@ endef
 define Device/wandboard
   DEVICE_TITLE := Wandboard Dual
   DEVICE_DTS := imx6dl-wandboard
-  DEVICE_PACKAGES := kmod-thermal-imx kmod-usb-chipidea-imx kmod-usb-mxs-phy
+  DEVICE_PACKAGES := kmod-usb-chipidea-imx kmod-usb-mxs-phy
 endef
 
 TARGET_DEVICES += \
index d977f9ab775c3e0524a00eb4db0d6534e7ce5e1f..9d981fdc02453a38e003dfb406875a2f6a09c5d1 100644 (file)
@@ -9,7 +9,7 @@ define Profile/Generic
   PRIORITY:=1
   NAME:=Generic (default)
   PACKAGES:= \
-       kmod-thermal-imx kmod-usb-chipidea-imx kmod-usb-mxs-phy
+       kmod-usb-chipidea-imx kmod-usb-mxs-phy
 endef
 
 define Profile/Generic/Description