ipip: remove setting default firewall zone to wan
authorHans Dedecker <dedeckeh@gmail.com>
Sat, 9 Feb 2019 19:48:11 +0000 (20:48 +0100)
committerHans Dedecker <dedeckeh@gmail.com>
Sat, 9 Feb 2019 20:04:08 +0000 (21:04 +0100)
Same reasoning as in bdedb798150a58ad7ce3c4741f2f31df97e84c3f; don't set
default firewall zone to wan as the firewall zone for the ipip interface
can be configured in the firewall config or it makes it impossible not to
specify a firewall zone for the ipip interface.

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/config/ipip/Makefile
package/network/config/ipip/files/ipip.sh

index 9bdb13c6bc7e5f6809a96274916c94715ab045e1..252534f198ed2c66dfcfc88db7812ac851ed75f3 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipip
 PKG_VERSION:=1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index f1c94d6eeddbeb47c566764998f4ce6504742b0d..15b1c978e31b1809021ce15aef4aa656b23886b7 100755 (executable)
@@ -47,8 +47,6 @@ proto_ipip_setup() {
                fi
        }
 
-       [ -z "$zone" ] && zone="wan"
-
        proto_init_update "ipip-$cfg" 1
 
        proto_add_tunnel