ramips: add support for Netgear WN3000RPv3
authorThibaut VARENE <hacks@slashdirt.org>
Wed, 18 Jan 2017 10:34:56 +0000 (11:34 +0100)
committerJohn Crispin <john@phrozen.org>
Wed, 18 Jan 2017 11:06:16 +0000 (12:06 +0100)
This patch adds support for the Netgear WN3000RPv3
http://www.netgear.com/support/product/wn3000rpv3.aspx

Specifications:
- SoC: MediaTek MT7620A (580MHz, ramips)
- RAM: 32MB DDR
- Storage: 8MB NOR SPI flash
- Wireless: builtin MT7620A, 2x2:2 with u.FL connectors
- Ethernet: 1x100M
- Serial: JP1 header, 57600-8N1
- Stock firmware based on OpenWRT Kamikaze

Like the EX2700, the bootloader expects a secondary image signature,
see https://forum.openwrt.org/viewtopic.php?pid=312577#p312577
This is why the same fakeroot image is used for the WN3000

Signed-off-by: Thibaut VARENE <hacks@slashdirt.org>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WN3000RPV3.dts [new file with mode: 0644]
target/linux/ramips/image/mt7620.mk

index 3d3aa0ac01a54faeaedf1af7577bdd6ddc2de6b2..545d6a4a6dcf93b088283e3bde7bf31923bf8584 100755 (executable)
@@ -155,7 +155,8 @@ vr500)
 dir-860l-b1)
        ucidef_set_led_netdev "wan" "wan" "$board:green:net" "eth0.2"
        ;;
 dir-860l-b1)
        ucidef_set_led_netdev "wan" "wan" "$board:green:net" "eth0.2"
        ;;
-ex2700)
+ex2700|\
+wn3000rpv3)
        ucidef_set_led_default "power_r" "POWER (red)" "$board:red:power" "0"
        set_wifi_led "$board:green:router"
        ;;
        ucidef_set_led_default "power_r" "POWER (red)" "$board:red:power" "0"
        set_wifi_led "$board:green:router"
        ;;
index e037cbce32b46811fa27c345e6675c3716c7e815..71c40a0ee41f4dc2271d5e0538f005badf87892c 100755 (executable)
@@ -58,6 +58,7 @@ ramips_setup_interfaces()
        timecloud|\
        w150m|\
        widora-neo|\
        timecloud|\
        w150m|\
        widora-neo|\
+       wn3000rpv3|\
        wnce2001|\
        zbt-cpe102|\
        zte-q7)
        wnce2001|\
        zbt-cpe102|\
        zte-q7)
index 5367e651ba23bc14b6f289ced15b094bf02eca3b..94998333b365ebe73a0cf7d6d8ae6e9be8790e64 100644 (file)
@@ -53,7 +53,8 @@ get_status_led() {
        jhr-n825r|\
        mpr-a1|\
        mpr-a2|\
        jhr-n825r|\
        mpr-a1|\
        mpr-a2|\
-       mzk-ex750np)
+       mzk-ex750np|\
+       wn3000rpv3)
                status_led="$board:red:power"
                ;;
        ac1200pro|\
                status_led="$board:red:power"
                ;;
        ac1200pro|\
index 6afe709cbe42e5c32f6009d850b2ce33fdfb0fc4..8292da1d4acf575512760651989ef64d108c8a6f 100755 (executable)
@@ -553,6 +553,9 @@ ramips_board_detect() {
        *"WMR-300")
                name="wmr-300"
                ;;
        *"WMR-300")
                name="wmr-300"
                ;;
+       *"WN3000RPv3")
+               name="wn3000rpv3"
+               ;;
        *"WNCE2001")
                name="wnce2001"
                ;;
        *"WNCE2001")
                name="wnce2001"
                ;;
index 0f2510c4bd81e5c4a2d35cd54db91e2fc44ca69f..c6ad8ca3e5262e300ba49f9d31b5bb874dc88380 100755 (executable)
@@ -157,6 +157,7 @@ platform_check_image() {
        wli-tx4-ag300n|\
        wlr-6000|\
        wmr-300|\
        wli-tx4-ag300n|\
        wlr-6000|\
        wmr-300|\
+       wn3000rpv3|\
        wnce2001|\
        wndr3700v5|\
        wr512-3gn|\
        wnce2001|\
        wndr3700v5|\
        wr512-3gn|\
diff --git a/target/linux/ramips/dts/WN3000RPV3.dts b/target/linux/ramips/dts/WN3000RPV3.dts
new file mode 100644 (file)
index 0000000..933cf1a
--- /dev/null
@@ -0,0 +1,143 @@
+/* This file is released into the public domain */
+
+/dts-v1/;
+
+#include "mt7620a.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+/ {
+       compatible = "ralink,mt7620a-soc";
+       model = "Netgear WN3000RPv3";
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power_g {
+                       label = "wn3000rpv3:green:power";
+                       gpios = <&gpio0 9 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               power_r {
+                       label = "wn3000rpv3:red:power";
+                       gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+               };
+
+               client_g {
+                       label = "wn3000rpv3:green:client";
+                       gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
+               };
+
+               client_r {
+                       label = "wn3000rpv3:red:client";
+                       gpios = <&gpio0 10 GPIO_ACTIVE_LOW>;
+               };
+
+               router_g {
+                       label = "wn3000rpv3:green:router";
+                       gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
+               };
+
+               router_r {
+                       label = "wn3000rpv3:red:router";
+                       gpios = <&gpio0 14 GPIO_ACTIVE_LOW>;
+               };
+
+               wps {
+                       label = "wn3000rpv3:green:wps";
+                       gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
+               };
+
+               l_arrow {
+                       label = "wn3000rpv3:blue:leftarrow";
+                       gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
+               };
+
+               r_arrow {
+                       label = "wn3000rpv3:blue:rightarrow";
+                       gpios = <&gpio0 8 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 2 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+       };
+};
+
+&gpio1 {
+       status = "okay";
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               partition@40000 {
+                       label = "firmware";
+                       reg = <0x40000 0x7b0000>;
+               };
+
+               art: partition@7f0000 {
+                       label = "art";
+                       reg = <0x7f0000 0x10000>;
+                       read-only;
+               };
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&art 0x0>;
+};
+
+&wmac {
+       mtd-mac-address = <&art 0x6>;
+       ralink,mtd-eeprom = <&art 0x1000>;
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               default {
+                       ralink,group = "i2c", "uartf", "spi refclk";
+                       ralink,function = "gpio";
+               };
+       };
+};
index 1889bcf708bf02d4b27f3df088a2cab238e3597d..42e0ab63c294d4607b83b444e36dd803810f7d93 100644 (file)
@@ -75,6 +75,17 @@ define Device/ex2700
 endef
 TARGET_DEVICES += ex2700
 
 endef
 TARGET_DEVICES += ex2700
 
+define Device/wn3000rpv3
+  DTS := WN3000RPV3
+  BLOCKSIZE := 4k
+  IMAGES += factory.bin
+  KERNEL := $(KERNEL_DTB) | uImage lzma | pad-kernel-ex2700
+  IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+       netgear-header -B WN3000RPv3 -H 29764836+8+0+32+2x2+0
+  DEVICE_TITLE := Netgear WN3000RPv3
+endef
+TARGET_DEVICES += wn3000rpv3
+
 define Device/wt3020-4M
   DTS := WT3020-4M
   BLOCKSIZE := 4k
 define Device/wt3020-4M
   DTS := WT3020-4M
   BLOCKSIZE := 4k