mt76: probe load mt7615 driver asynchronously
authorFelix Fietkau <nbd@nbd.name>
Thu, 12 Sep 2019 15:15:40 +0000 (17:15 +0200)
committerFelix Fietkau <nbd@nbd.name>
Thu, 12 Sep 2019 15:16:44 +0000 (17:16 +0200)
It can take a long time to load the firmware

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/mt76/Makefile

index db0bf04d0ad66ed73bb387b562bc5914b992d6fc..49687a6a3c1c044eb42343eb57b2a6875240457e 100644 (file)
@@ -144,6 +144,7 @@ define KernelPackage/mt7615e
   DEPENDS+=@PCI_SUPPORT +kmod-mt76-core
   FILES:=\
        $(PKG_BUILD_DIR)/mt7615/mt7615e.ko
   DEPENDS+=@PCI_SUPPORT +kmod-mt76-core
   FILES:=\
        $(PKG_BUILD_DIR)/mt7615/mt7615e.ko
+  MODPARAMS:=async_probe
   AUTOLOAD:=$(call AutoProbe,mt7615e)
 endef
 
   AUTOLOAD:=$(call AutoProbe,mt7615e)
 endef