kernel: update 4.0 to 4.0.7
authorJonas Gorski <jogo@openwrt.org>
Tue, 30 Jun 2015 23:26:13 +0000 (23:26 +0000)
committerJonas Gorski <jogo@openwrt.org>
Tue, 30 Jun 2015 23:26:13 +0000 (23:26 +0000)
Changelog:
* https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.0.6
* https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.0.7

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46151

include/kernel-version.mk
target/linux/generic/patches-4.0/180-usb-xhci-make-USB_XHCI_PLATFORM-selectable.patch
target/linux/generic/patches-4.0/645-bridge_multicast_to_unicast.patch
target/linux/generic/patches-4.0/653-disable_netlink_trim.patch
target/linux/generic/patches-4.0/664-codel_fix_3_12.patch
target/linux/oxnas/patches-4.0/800-oxnas-ehci.patch

index 8bac82461bf06820bd1f6a4e626c5f6a92ac8658..fd1efdbfbd34df7f1b93f567a8c48ce35130f8a1 100644 (file)
@@ -3,11 +3,11 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .17
-LINUX_VERSION-4.0 = .5
+LINUX_VERSION-4.0 = .7
 LINUX_VERSION-4.1 =
 
 LINUX_KERNEL_MD5SUM-3.18.17 = f05d7620c587d8b0ab3cd944ff9dc9f7
-LINUX_KERNEL_MD5SUM-4.0.5 = 214836ae60a5674c31bb7cede5f47794
+LINUX_KERNEL_MD5SUM-4.0.7 = 7993e5389c189d5c7dbc21135aebc0c1
 LINUX_KERNEL_MD5SUM-4.1 = fe9dc0f6729f36400ea81aa41d614c37
 
 ifdef KERNEL_PATCHVER
index e86ab3f5653e731b1819249e662ca5e5b55eaa51..a17e39800c2e1bc763eab1ac5c457a30e5a2c0d3 100644 (file)
@@ -21,8 +21,6 @@ V2: Drop useless "default n", thanks Sergei :)
  drivers/usb/host/Kconfig | 9 ++++++++-
  1 file changed, 8 insertions(+), 1 deletion(-)
 
-diff --git a/drivers/usb/host/Kconfig b/drivers/usb/host/Kconfig
-index 197a6a3..688698a 100644
 --- a/drivers/usb/host/Kconfig
 +++ b/drivers/usb/host/Kconfig
 @@ -32,7 +32,14 @@ config USB_XHCI_PCI
@@ -41,6 +39,3 @@ index 197a6a3..688698a 100644
  
  config USB_XHCI_MVEBU
        tristate "xHCI support for Marvell Armada 375/38x"
--- 
-1.8.4.5
-
index f09875c02c14745009fdb3be29849b28a1d6b6f5..2b0b42f2c3bb074ab15a681353c90f35d4fb5dac 100644 (file)
                err = br_ip6_multicast_add_group(br, port, &grec->grec_mca,
 -                                               vid);
 +                                               vid, src);
-               if (!err)
+               if (err)
                        break;
        }
 @@ -1407,7 +1434,8 @@ br_multicast_leave_group(struct net_brid
index f3231db0938b2436b7cea50eeee7e67a0b777c3d..02ab826aeda5860c40f66dbbaf55918a2066f0f0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netlink/af_netlink.c
 +++ b/net/netlink/af_netlink.c
-@@ -1710,27 +1710,7 @@ void netlink_detachskb(struct sock *sk,
+@@ -1713,27 +1713,7 @@ void netlink_detachskb(struct sock *sk,
  
  static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
  {
index 2682441b1cfcda5dd11353b0c12883b8be33ff8a..726c428e5605f2b6c217f60f7440a9b7a9957a8e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/sched/sch_api.c
 +++ b/net/sched/sch_api.c
-@@ -1945,7 +1945,7 @@ static int __init pktsched_init(void)
+@@ -1947,7 +1947,7 @@ static int __init pktsched_init(void)
                return err;
        }
  
index ea47d3bf0c4767453f613adc71c443f8b70ba157..b283bbd3f66a9395b3f247ea0402bfbadd84f9c2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/host/Kconfig
 +++ b/drivers/usb/host/Kconfig
-@@ -306,6 +306,13 @@ config USB_OCTEON_EHCI
+@@ -313,6 +313,13 @@ config USB_OCTEON_EHCI
          USB 2.0 device support.  All CN6XXX based chips with USB are
          supported.