util-linux: Fix build when libmagic is present
authorRosen Penev <rosenp@gmail.com>
Tue, 1 Sep 2020 22:37:03 +0000 (15:37 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 6 Sep 2020 21:19:12 +0000 (23:19 +0200)
When the libmagic from the file package in the packages feed was also
compiled and provided its libmagic.so file, util-linux tried to link
against it. Avoid this by explicitly disable libmagic support.

This fixes the following build error:
Package more is missing dependencies for the following libraries:
libmagic.so.1

Fixes: 36d9ed360a34 ("util-linux: update to 2.36")
Acked-by: Sebastian Kemper <sebastian_ml@gmx.net>
Signed-off-by: Rosen Penev <rosenp@gmail.com>
[Add commit description]
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/utils/util-linux/Makefile

index 0fc9819c587090e7dad308d303581dafdbee3d16..05ceaa413e9c0488dd497860ec49ad51aec9098e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
 PKG_VERSION:=2.36
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.36
@@ -526,6 +526,7 @@ CONFIGURE_ARGS += \
        --without-python                \
        --without-udev                  \
        --without-readline              \
+       --without-libmagic              \
        --with-ncursesw
 
 TARGET_CFLAGS += $(FPIC) -std=gnu99