kernel: bump 4.14 to 4.14.138
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 12 Aug 2019 09:30:09 +0000 (11:30 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 14 Aug 2019 16:23:08 +0000 (18:23 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/pending-4.14/220-optimize_inlining.patch
target/linux/generic/pending-4.14/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
target/linux/mvebu/patches-4.14/408-sfp-move-module-eeprom-ethtool-access-into-netdev-co.patch
target/linux/mvebu/patches-4.14/409-sfp-use-netdev-sfp_bus-for-start-stop.patch

index 14aaac220bfc160e0ca060ba3535051fdd0bb83c..fff92f6f07315a6d6e6c76523dad3f19cb12f182 100644 (file)
@@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.9 = .189
-LINUX_VERSION-4.14 = .137
+LINUX_VERSION-4.14 = .138
 LINUX_VERSION-4.19 = .65
 
 LINUX_KERNEL_HASH-4.9.189 = 93d945661246f726b694455c80c140717d2beff5a718445a51183439bbe5d0b3
-LINUX_KERNEL_HASH-4.14.137 = 93f8e91329300f325a5b4dd9de1f51c0b1bf9591dfd2274044c2f70f96bae228
+LINUX_KERNEL_HASH-4.14.138 = f250bd1de3a83c1f015f8e6e9bfa9f20eaef3dc24a6cd60116e49979314b837b
 LINUX_KERNEL_HASH-4.19.65 = e59939186916c0286289c5bf78b83fac0d71a807241c6b1899bfe7a84486dedf
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index fd90ad743fcb6277f98ccfbb1f4cf2c3067af668..d99294e3718912a70dc33921829ab35f665fb5b3 100644 (file)
@@ -65,7 +65,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
         * Before updating sk_refcnt, we must commit prior changes to memory
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -1687,7 +1687,7 @@ u32 tcp_tso_autosize(const struct sock *
+@@ -1696,7 +1696,7 @@ u32 tcp_tso_autosize(const struct sock *
  {
        u32 bytes, segs;
  
@@ -74,7 +74,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
                    sk->sk_gso_max_size - 1 - MAX_TCP_HEADER);
  
        /* Goal is to send at least one packet per ms,
-@@ -2204,7 +2204,7 @@ static bool tcp_small_queue_check(struct
+@@ -2213,7 +2213,7 @@ static bool tcp_small_queue_check(struct
  {
        unsigned int limit;
  
index 12b875848e66ad56a870bd3f47f3550d2cd160be..ff2bed17f31cdfd964a90e7e434225e3900ff0aa 100644 (file)
@@ -11,7 +11,7 @@
        early_print("no ATAGS support: can't continue\n");
 --- a/arch/arm64/include/asm/cpufeature.h
 +++ b/arch/arm64/include/asm/cpufeature.h
-@@ -125,7 +125,7 @@ static inline bool cpu_have_feature(unsi
+@@ -126,7 +126,7 @@ static inline bool cpu_have_feature(unsi
  }
  
  /* System capability check for constant caps */
@@ -20,7 +20,7 @@
  {
        if (num >= ARM64_NCAPS)
                return false;
-@@ -139,7 +139,7 @@ static inline bool cpus_have_cap(unsigne
+@@ -140,7 +140,7 @@ static inline bool cpus_have_cap(unsigne
        return test_bit(num, cpu_hwcaps);
  }
  
index 89e6646c5724f81c2654a7758fb1a4aa53a3101c..6e2eca6dafc2fe77eaecc1bf6bc73ca9066a61f7 100644 (file)
@@ -300,7 +300,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  /**
   * ip6_tnl_addr_conflict - compare packet addresses to tunnel's own
   *   @t: the outgoing tunnel device
-@@ -1306,6 +1446,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1305,6 +1445,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
  {
        struct ip6_tnl *t = netdev_priv(dev);
        struct ipv6hdr *ipv6h;
@@ -309,8 +309,8 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        __u16 offset;
        struct flowi6 fl6;
 @@ -1372,6 +1513,18 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
        fl6.flowi6_uid = sock_net_uid(dev_net(dev), NULL);
+       dsfield = INET_ECN_encapsulate(dsfield, ipv6_get_dsfield(ipv6h));
  
 +      /* try to find matching FMR */
 +      for (fmr = t->parms.fmrs; fmr; fmr = fmr->next) {
@@ -327,7 +327,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        if (iptunnel_handle_offloads(skb, SKB_GSO_IPXIP6))
                return -1;
  
-@@ -1500,6 +1653,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
+@@ -1498,6 +1651,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
        t->parms.link = p->link;
        t->parms.proto = p->proto;
        t->parms.fwmark = p->fwmark;
@@ -342,7 +342,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        dst_cache_reset(&t->dst_cache);
        ip6_tnl_link_config(t);
        return 0;
-@@ -1538,6 +1699,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
+@@ -1536,6 +1697,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
        p->flowinfo = u->flowinfo;
        p->link = u->link;
        p->proto = u->proto;
@@ -350,7 +350,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        memcpy(p->name, u->name, sizeof(u->name));
  }
  
-@@ -1924,6 +2086,15 @@ static int ip6_tnl_validate(struct nlatt
+@@ -1922,6 +2084,15 @@ static int ip6_tnl_validate(struct nlatt
        return 0;
  }
  
@@ -366,7 +366,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  static void ip6_tnl_netlink_parms(struct nlattr *data[],
                                  struct __ip6_tnl_parm *parms)
  {
-@@ -1961,6 +2132,46 @@ static void ip6_tnl_netlink_parms(struct
+@@ -1959,6 +2130,46 @@ static void ip6_tnl_netlink_parms(struct
  
        if (data[IFLA_IPTUN_FWMARK])
                parms->fwmark = nla_get_u32(data[IFLA_IPTUN_FWMARK]);
@@ -413,7 +413,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  }
  
  static bool ip6_tnl_netlink_encap_parms(struct nlattr *data[],
-@@ -2076,6 +2287,12 @@ static void ip6_tnl_dellink(struct net_d
+@@ -2074,6 +2285,12 @@ static void ip6_tnl_dellink(struct net_d
  
  static size_t ip6_tnl_get_size(const struct net_device *dev)
  {
@@ -426,7 +426,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        return
                /* IFLA_IPTUN_LINK */
                nla_total_size(4) +
-@@ -2105,6 +2322,24 @@ static size_t ip6_tnl_get_size(const str
+@@ -2103,6 +2320,24 @@ static size_t ip6_tnl_get_size(const str
                nla_total_size(0) +
                /* IFLA_IPTUN_FWMARK */
                nla_total_size(4) +
@@ -451,7 +451,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
                0;
  }
  
-@@ -2112,6 +2347,9 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -2110,6 +2345,9 @@ static int ip6_tnl_fill_info(struct sk_b
  {
        struct ip6_tnl *tunnel = netdev_priv(dev);
        struct __ip6_tnl_parm *parm = &tunnel->parms;
@@ -461,7 +461,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  
        if (nla_put_u32(skb, IFLA_IPTUN_LINK, parm->link) ||
            nla_put_in6_addr(skb, IFLA_IPTUN_LOCAL, &parm->laddr) ||
-@@ -2121,9 +2359,27 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -2119,9 +2357,27 @@ static int ip6_tnl_fill_info(struct sk_b
            nla_put_be32(skb, IFLA_IPTUN_FLOWINFO, parm->flowinfo) ||
            nla_put_u32(skb, IFLA_IPTUN_FLAGS, parm->flags) ||
            nla_put_u8(skb, IFLA_IPTUN_PROTO, parm->proto) ||
@@ -490,7 +490,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        if (nla_put_u16(skb, IFLA_IPTUN_ENCAP_TYPE, tunnel->encap.type) ||
            nla_put_be16(skb, IFLA_IPTUN_ENCAP_SPORT, tunnel->encap.sport) ||
            nla_put_be16(skb, IFLA_IPTUN_ENCAP_DPORT, tunnel->encap.dport) ||
-@@ -2163,6 +2419,7 @@ static const struct nla_policy ip6_tnl_p
+@@ -2161,6 +2417,7 @@ static const struct nla_policy ip6_tnl_p
        [IFLA_IPTUN_ENCAP_DPORT]        = { .type = NLA_U16 },
        [IFLA_IPTUN_COLLECT_METADATA]   = { .type = NLA_FLAG },
        [IFLA_IPTUN_FWMARK]             = { .type = NLA_U32 },
index 3fd07d231ff7e025a6a0877f3af779cab4c4519a..a5efa258385d3be91146695ba6c467e9075b45ce 100644 (file)
@@ -49,7 +49,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
  };
 --- a/drivers/net/phy/phylink.c
 +++ b/drivers/net/phy/phylink.c
-@@ -1058,34 +1058,6 @@ int phylink_ethtool_set_pauseparam(struc
+@@ -1060,34 +1060,6 @@ int phylink_ethtool_set_pauseparam(struc
  }
  EXPORT_SYMBOL_GPL(phylink_ethtool_set_pauseparam);
  
index 4db3867c4ec58d02d3eede7c80515530dc5ef63c..10bd2d0a46cd06648c1ba4b40425343e19a56bac 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
 
 --- a/drivers/net/phy/phylink.c
 +++ b/drivers/net/phy/phylink.c
-@@ -775,8 +775,8 @@ void phylink_start(struct phylink *pl)
+@@ -777,8 +777,8 @@ void phylink_start(struct phylink *pl)
        clear_bit(PHYLINK_DISABLE_STOPPED, &pl->phylink_disable_state);
        phylink_run_resolve(pl);
  
@@ -21,7 +21,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
        if (pl->phydev)
                phy_start(pl->phydev);
  }
-@@ -788,8 +788,8 @@ void phylink_stop(struct phylink *pl)
+@@ -790,8 +790,8 @@ void phylink_stop(struct phylink *pl)
  
        if (pl->phydev)
                phy_stop(pl->phydev);