revert CONFIG_* symbols set m enforcement introduced in [8591], it can't work when...
authorNicolas Thill <nico@openwrt.org>
Sun, 16 Sep 2007 16:10:37 +0000 (16:10 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 16 Sep 2007 16:10:37 +0000 (16:10 +0000)
SVN-Revision: 8798

include/kernel.mk
include/netfilter.mk

index 788e3f2378fe87b9ca78c1fe64bb5073cdc11bf1..748605705289425a6363d8855557476845253b4c 100644 (file)
@@ -115,8 +115,7 @@ $(call KernelPackage/$(1)/description)
     endef
   endif
 
-  # check that all CONFIG_* symbols in $(KCONFIG) are set to 'm'
-  ifeq ($(filter-out m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$(if $($(c)),$($(c)),n))),)
+  ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
                  mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
index 6f77f9670cd46b6670dbfbfc1daf330a0f64f398..35efc039c4de9fad1e891b783a38d4185ae9200d 100644 (file)
@@ -16,9 +16,7 @@ endif
 
 define nf_add
  $(1)-$$($(2)) += $(3)
- ifeq ($$($(2)),m)
-  KCONFIG_$(1) += $(2)
- endif
+ KCONFIG_$(1) += $(2)
 endef
 
 IPT_CONNTRACK-m :=