ramips: Add support for Phicomm PSG1208
authorJohn Crispin <john@openwrt.org>
Mon, 15 Feb 2016 18:45:22 +0000 (18:45 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 15 Feb 2016 18:45:22 +0000 (18:45 +0000)
This patch adds support for Phicomm PSG1208.This is a router with MT7620A SoC with 8M flash and 64M ram.
The WPS led is uesd as status_led because the power light can't be controlled with GPIO.
It seems that the 5g wifi led is connected to MT7612E and it can't be controlled with GPIO too.

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
SVN-Revision: 48721

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/PSG1208.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/mt7620/profiles/phicomm.mk [new file with mode: 0644]

index b10f5f1eba9329d86d87915df1aff56edfbebb11..d1b4e159aeff680dcfadde0f54bbedd63cc19d69 100755 (executable)
@@ -208,6 +208,9 @@ pbr-m1)
        ucidef_set_led_default "power" "power" "$board:blue:power" "1"
        ucidef_set_led_default "sys" "sys" "$board:blue:sys" "1"
        ;;
+psg1208)
+       set_wifi_led "$board:white:wlan2g"
+       ;;
 px-4885)
        set_wifi_led "$board:orange:wifi"
        set_usb_led "$board:blue:storage"
index 98537292b12566e5d7f40a5ba6ae940d4f27b625..0121e51665b184d1e3ba90a906b3575f3851abc0 100755 (executable)
@@ -74,6 +74,7 @@ ramips_setup_interfaces()
        mzk-w300nh2|\
        oy-0001|\
        pbr-m1|\
+       psg1208|\
        sap-g3200u3|\
        wf-2881|\
        whr-300hp2|\
index 59c59653960dca86b7512813d01ea35088fe5c64..c7c7815b25417f5af0ca66f4fbb1ca546d5c77e9 100644 (file)
@@ -75,7 +75,8 @@ get_status_led() {
        dir-645)
                status_led="$board:green:wps"
                ;;
-       cf-wr800n)
+       cf-wr800n|\
+       psg1208)
                status_led="$board:white:wps"
                ;;
        cy-swr1100|\
index aed8350291da9a3b87c385099a89573661549769..c6c32fe7dbbdbf10aaf5574645ac99ff66c0f065 100755 (executable)
@@ -292,6 +292,9 @@ ramips_board_detect() {
        *"PBR-M1")
                name="pbr-m1"
                ;;
+       *"PSG1208")
+               name="psg1208"
+               ;;
        *"PSR-680W"*)
                name="psr-680w"
                ;;
index 78edd221640647c1802e0cd530ce5a04fd5a746d..5575b4c980e943b515fd5cf777979e5ac4a19950 100755 (executable)
@@ -84,6 +84,7 @@ platform_check_image() {
        nw718|\
        oy-0001|\
        pbr-m1|\
+       psg1208|\
        psr-680w|\
        px-4885|\
        re6500|\
diff --git a/target/linux/ramips/dts/PSG1208.dts b/target/linux/ramips/dts/PSG1208.dts
new file mode 100644 (file)
index 0000000..c3be8ef
--- /dev/null
@@ -0,0 +1,114 @@
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+/ {
+       compatible = "PSG1208", "ralink,mt7620a-soc";
+       model = "Phicomm PSG1208";
+
+       palmbus@10000000 {
+               gpio1: gpio@638 {
+                       status = "okay";
+               };
+
+               gpio3: gpio@688 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "jedec,spi-nor";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "en25q64";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@20000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@30000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@40000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x7b0000>;
+                               };
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "uartf", "rgmii1", "rgmii2", "ephy", "wled", "nd_sd";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               pinctrl-names = "default";
+               pinctrl-0 = <&ephy_pins>;
+               mtd-mac-address = <&factory 0x4>;
+               mediatek,portmap = "llllw";
+       };
+
+       pcie@10140000 {
+               status = "okay";
+
+               pcie-bridge {
+                       mt76@0,0 {
+                               reg = <0x0000 0 0 0 0>;
+                               device_type = "pci";
+                               mediatek,mtd-eeprom = <&factory 0x8000>;
+                               mediatek,2ghz = <0>;
+                       };
+               };
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               wan {
+                       label = "psg1208:white:wps";
+                       gpios = <&gpio1 15 1>;
+               };
+
+               wlan {
+                       label = "psg1208:white:wlan2g";
+                       gpios = <&gpio3 0 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 1>;
+                       linux,code = <0x198>;
+               };
+       };
+};
index a42f8b9dbce9f3b6e39ac450aed13a80abc9e270..8bdd76a35cf92e8572cf7196efbcb119eb5be841 100644 (file)
@@ -937,6 +937,7 @@ Image/Build/Profile/HC5661=$(call BuildFirmware/Default16M/$(1),$(1),hc5661,HC56
 Image/Build/Profile/HC5761=$(call BuildFirmware/Default16M/$(1),$(1),hc5761,HC5761)
 Image/Build/Profile/HC5861=$(call BuildFirmware/Default16M/$(1),$(1),hc5861,HC5861)
 Image/Build/Profile/OY-0001=$(call BuildFirmware/Default16M/$(1),$(1),oy-0001,OY-0001)
+Image/Build/Profile/PSG1208=$(call BuildFirmware/Default8M/$(1),$(1),psg1208,PSG1208)
 Image/Build/Profile/Y1=$(call BuildFirmware/Default16M/$(1),$(1),y1,Y1)
 Image/Build/Profile/Y1S=$(call BuildFirmware/Default16M/$(1),$(1),y1s,Y1S)
 Image/Build/Profile/MLW221=$(call BuildFirmware/Default16M/$(1),$(1),mlw221,MLW221)
@@ -978,6 +979,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/HC5761,$(1))
        $(call Image/Build/Profile/HC5861,$(1))
        $(call Image/Build/Profile/OY-0001,$(1))
+       $(call Image/Build/Profile/PSG1208,$(1))
        $(call Image/Build/Profile/Y1,$(1))
        $(call Image/Build/Profile/Y1S,$(1))
        $(call Image/Build/Profile/MLW221,$(1))
diff --git a/target/linux/ramips/mt7620/profiles/phicomm.mk b/target/linux/ramips/mt7620/profiles/phicomm.mk
new file mode 100644 (file)
index 0000000..e083a4c
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/PSG1208
+       NAME:=Phicomm PSG1208
+       PACKAGES:=kmod-mt76
+endef
+
+define Profile/PSG1208/Description
+       Default package set for Phicomm PSG1208.
+endef
+$(eval $(call Profile,PSG1208))