ath79: rename ubnt_bullet-m to ubnt_bullet-m-ar7241
authorRussell Senior <russell@personaltelco.net>
Wed, 11 Mar 2020 01:06:03 +0000 (18:06 -0700)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 18 Mar 2020 12:45:57 +0000 (13:45 +0100)
Since there exists another variant of the Bullet M with AR7240 SoC
under the same name, this patch introduces the SoC into the device
name to be able to distinguish these variants.

Signed-off-by: Russell Senior <russell@personaltelco.net>
[add commit message, adjust model in DTS, fix 02_network and
SUPPORTED_DEVICES]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/dts/ar7241_ubnt_bullet-m-ar7241.dts [new file with mode: 0644]
target/linux/ath79/dts/ar7241_ubnt_bullet-m.dts [deleted file]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/image/generic-ubnt.mk

diff --git a/target/linux/ath79/dts/ar7241_ubnt_bullet-m-ar7241.dts b/target/linux/ath79/dts/ar7241_ubnt_bullet-m-ar7241.dts
new file mode 100644 (file)
index 0000000..0e2183c
--- /dev/null
@@ -0,0 +1,15 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar7241.dtsi"
+#include "ar724x_ubnt_xm.dtsi"
+#include "ar724x_ubnt_xm_outdoor.dtsi"
+
+/ {
+       compatible = "ubnt,bullet-m-ar7241", "ubnt,xm", "qca,ar7241";
+       model = "Ubiquiti Bullet M XM (AR7241)";
+};
+
+&eth1 {
+       compatible = "syscon", "simple-mfd";
+};
diff --git a/target/linux/ath79/dts/ar7241_ubnt_bullet-m.dts b/target/linux/ath79/dts/ar7241_ubnt_bullet-m.dts
deleted file mode 100644 (file)
index a43ed2a..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include "ar7241.dtsi"
-#include "ar724x_ubnt_xm.dtsi"
-#include "ar724x_ubnt_xm_outdoor.dtsi"
-
-/ {
-       compatible = "ubnt,bullet-m", "ubnt,xm", "qca,ar7241";
-       model = "Ubiquiti Bullet M";
-};
-
-&eth1 {
-       compatible = "syscon", "simple-mfd";
-};
index 390f5f3657e51b5441a5a855a92fec634b86e7de..cf9dfd2b0d5d0b8a247e48173daeff678f7a91aa 100755 (executable)
@@ -245,7 +245,7 @@ tplink,tl-wr842n-v2)
 trendnet,tew-823dru)
        ucidef_set_led_netdev "wan" "WAN" "trendnet:green:planet" "eth0"
        ;;
-ubnt,bullet-m|\
+ubnt,bullet-m-ar7241|\
 ubnt,bullet-m-xw|\
 ubnt,nanostation-loco-m|\
 ubnt,nanostation-loco-m-xw|\
index 6f9aed8bf575c92453576182d278ac1b28cc2390..79313e9170874f4a932193b99f7312cd7f55e85b 100755 (executable)
@@ -40,7 +40,7 @@ ath79_setup_interfaces()
        tplink,re450-v1|\
        tplink,re450-v2|\
        tplink,tl-wr902ac-v1|\
-       ubnt,bullet-m|\
+       ubnt,bullet-m-ar7241|\
        ubnt,bullet-m-xw|\
        ubnt,lap-120|\
        ubnt,litebeam-ac-gen2|\
@@ -440,7 +440,7 @@ ath79_setup_macs()
                label_mac=$wan_mac
                ;;
        ubnt,airrouter|\
-       ubnt,bullet-m|\
+       ubnt,bullet-m-ar7241|\
        ubnt,nanostation-loco-m|\
        ubnt,nanostation-m|\
        ubnt,picostation-m|\
index 52a1502af445c0429f18b372430ea8665886509d..38f158896b01b7b005cbc6185a04727a54036afe 100644 (file)
@@ -85,7 +85,7 @@ case "$FIRMWARE" in
        tplink,tl-wr2543-v1|\
        tplink,tl-wr842n-v1|\
        ubnt,airrouter|\
-       ubnt,bullet-m|\
+       ubnt,bullet-m-ar7241|\
        ubnt,nanostation-loco-m|\
        ubnt,nanostation-m|\
        ubnt,picostation-m|\
index aad177bf4a6138db443bd4eee6023a43468c8dbd..49020230894233b5982fd1d225129bd40309d250 100644 (file)
@@ -113,14 +113,15 @@ define Device/ubnt_airrouter
 endef
 TARGET_DEVICES += ubnt_airrouter
 
-define Device/ubnt_bullet-m
+define Device/ubnt_bullet-m-ar7241
   $(Device/ubnt-xm)
   SOC := ar7241
   DEVICE_MODEL := Bullet-M
+  DEVICE_VARIANT := XM (AR7241)
   DEVICE_PACKAGES += rssileds
-  SUPPORTED_DEVICES += bullet-m
+  SUPPORTED_DEVICES += bullet-m ubnt,bullet-m
 endef
-TARGET_DEVICES += ubnt_bullet-m
+TARGET_DEVICES += ubnt_bullet-m-ar7241
 
 define Device/ubnt_bullet-m-xw
   $(Device/ubnt-xw)