brcm2708: improve profiles and image generation
authorJohn Crispin <john@openwrt.org>
Fri, 17 Jul 2015 12:47:50 +0000 (12:47 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 17 Jul 2015 12:47:50 +0000 (12:47 +0000)
- Add profiles for bcm2708 subtarget.
- Check subtarget for image generation.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 46396

target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk
target/linux/brcm2708/image/Makefile

index 94d0a068c065d7a835734ac798647405bea477f0..82a7910ba1089e6c2c324139d1b18c6c42d5cd78 100644 (file)
@@ -5,12 +5,26 @@
 # See /LICENSE for more information.
 #
 
-define Profile/RaspberryPi
+define Profile/Default
   NAME:=Raspberry Pi
 endef
+define Profile/Default/Description
+  Raspberry Pi
+endef
+$(eval $(call Profile,Default))
 
-define Profile/RaspberryPi/Description
-       Raspberry Pi board
+define Profile/RaspberryPi_B
+  NAME:=Raspberry Pi Model B
+endef
+define Profile/RaspberryPi_B/Description
+  Raspberry Pi Model B
 endef
+$(eval $(call Profile,RaspberryPi_B))
 
-$(eval $(call Profile,RaspberryPi))
+define Profile/RaspberryPi_BPlus
+  NAME:=Raspberry Pi Model B+
+endef
+define Profile/RaspberryPi_BPlus/Description
+  Raspberry Pi Model B+
+endef
+$(eval $(call Profile,RaspberryPi_BPlus))
index d3d1617176aa80441a3daacc91ca7b786396239b..ef7483d8414bb83f6c3934981bb1f2e72432457c 100644 (file)
@@ -5,12 +5,10 @@
 # See /LICENSE for more information.
 #
 
-define Profile/RaspberryPi2
-  NAME:=Raspberry Pi 2
+define Profile/RaspberryPi_2
+  NAME:=Raspberry Pi 2 Model B
 endef
-
-define Profile/RaspberryPi2/Description
-       Raspberry Pi 2 board
+define Profile/RaspberryPi_2/Description
+  Raspberry Pi 2 Model B
 endef
-
-$(eval $(call Profile,RaspberryPi2))
+$(eval $(call Profile,RaspberryPi_2))
index 10ecfdaef013b58333c49a388725d25a685172b7..00bee225550748da25b40c0696d45ea5f872c9c9 100644 (file)
@@ -67,11 +67,18 @@ define add_bcm2708
   TARGET_DEVICES += $(2)
 endef
 
-# Raspberry Pi Model B
-$(eval $(call add_bcm2708,RaspberryPi,rpi-b,bcm2708-rpi-b))
-# Raspberry Pi Model B+
-$(eval $(call add_bcm2708,RaspberryPi,rpi-b-plus,bcm2708-rpi-b-plus))
-# Raspberry Pi 2 Model B
-$(eval $(call add_bcm2708,RaspberryPi2,rpi-2-b,bcm2709-rpi-2-b))
+### BCM2708/BCM2835 ###
+ifeq ($(SUBTARGET),bcm2708)
+  # Raspberry Pi Model B
+  $(eval $(call add_bcm2708,RaspberryPi_B,rpi-b,bcm2708-rpi-b))
+  # Raspberry Pi Model B+
+  $(eval $(call add_bcm2708,RaspberryPi_BPlus,rpi-b-plus,bcm2708-rpi-b-plus))
+endif
+
+### BCM2709/BCM2836 ###
+ifeq ($(SUBTARGET),bcm2709)
+  # Raspberry Pi 2 Model B
+  $(eval $(call add_bcm2708,RaspberryPi_2,rpi-2-b,bcm2709-rpi-2-b))
+endif
 
 $(eval $(call BuildImage))