dnsmasq: Fix dhcp-boot, dhcp-reply-delay and pxe-prompt regressions
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Fri, 14 Dec 2018 14:06:27 +0000 (14:06 +0000)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Fri, 14 Dec 2018 17:51:42 +0000 (17:51 +0000)
The above options were incorrectly changed to required tags.  Make them
optional again.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/network/services/dnsmasq/Makefile
package/network/services/dnsmasq/patches/0014-option-dhcp-boot-dhcp-reply-delay-tag-fixes.patch [new file with mode: 0644]

index 229d9eb4a0c2ec1fb1a72a53ed703fddbeb069f4..fc067ebb0f22bad3ce89d92394d0b8c8e78afcfe 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.80
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/network/services/dnsmasq/patches/0014-option-dhcp-boot-dhcp-reply-delay-tag-fixes.patch b/package/network/services/dnsmasq/patches/0014-option-dhcp-boot-dhcp-reply-delay-tag-fixes.patch
new file mode 100644 (file)
index 0000000..7712a32
--- /dev/null
@@ -0,0 +1,40 @@
+From 668b45c29c38d440c8fce4bc994c56910adc3919 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20Men=C5=A1=C3=ADk?= <pemensik@redhat.com>
+Date: Fri, 14 Dec 2018 17:03:08 +0100
+Subject: [PATCH] Fix required tags in few places
+
+Some locations were incorrectly changed to require always tags, else
+dnsmasq will not start. Fix dhcp-boot, dhcp-reply-delay and pxe-prompt.
+---
+ src/option.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+--- a/src/option.c
++++ b/src/option.c
+@@ -3434,7 +3434,7 @@ static int one_opt(int option, char *arg
+       {
+       struct dhcp_netid *id = dhcp_tags(&arg);
+       
+-      if (!id)
++      if (!arg)
+         {
+           ret_err(gen_err);
+         }
+@@ -3485,7 +3485,7 @@ static int one_opt(int option, char *arg
+       {
+       struct dhcp_netid *id = dhcp_tags(&arg);
+       
+-      if (!id)
++      if (!arg)
+         {
+           ret_err(gen_err);
+         }
+@@ -3515,7 +3515,7 @@ static int one_opt(int option, char *arg
+        new->opt = 10; /* PXE_MENU_PROMPT */
+        new->netid = dhcp_tags(&arg);
+        
+-       if (!new->netid)
++       if (!arg)
+          {
+            dhcp_opt_free(new);
+            ret_err(gen_err);