tools: libressl: always build as PIC
authorMatthias Schiffer <mschiffer@universe-factory.net>
Tue, 10 Jan 2017 21:10:59 +0000 (22:10 +0100)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Tue, 10 Jan 2017 21:15:37 +0000 (22:15 +0100)
Fixes link errors for host packages like ruby like the following:

/usr/bin/ld: .../staging_dir/host/lib/libcrypto.a(libcrypto_la-md5_dgst.o):
relocation R_X86_64_PC32 against symbol `memcpy@@GLIBC_2.14' can not be used when making a shared object; recompile with -fPIC

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
tools/libressl/Makefile

index 1e3a6f80fbd3437c742e0997e3527540a2daa525..be6a48be282ccc2d1ab0d168bc7376a651732378 100644 (file)
@@ -22,5 +22,6 @@ HOST_BUILD_PARALLEL:=1
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += --disable-shared
+HOST_CFLAGS += $(FPIC)
 
 $(eval $(call HostBuild))