ensure accidentally installed *.la-files (into $STAGING_DIR) are going to be removed...
authorMirko Vogt <mirko@openwrt.org>
Sat, 4 Dec 2010 13:44:43 +0000 (13:44 +0000)
committerMirko Vogt <mirko@openwrt.org>
Sat, 4 Dec 2010 13:44:43 +0000 (13:44 +0000)
SVN-Revision: 24241

include/autotools.mk

index 7e251ead533dc995aa479f63bfccb4e8edc5732f..20227474cb03ef01f7891cfa47abb3bbd464f3d5 100644 (file)
@@ -49,6 +49,14 @@ define remove_version_check
        fi
 endef
 
+# delete *.la-files from staging_dir - we can not yet remove respective lines within all package
+# Makefiles, since backfire still uses libtool v1.5.x which (may) require those files
+define libtool_remove_files
+       find $(1) -name '*.la' | $(XARGS) rm -f
+endef
+
+Hooks/InstallDev/Post += libtool_remove_files
+
 # XXX the libtool fixups got deactivated in the course of switching to libtool2 in trunk XXX
 # ifneq ($(filter libtool,$(PKG_FIXUP)),)
 #   PKG_BUILD_DEPENDS += libtool