ramips: remove old build code seama recipe
authorMathias Kresin <dev@kresin.me>
Sat, 3 Sep 2016 13:27:46 +0000 (15:27 +0200)
committerMathias Kresin <dev@kresin.me>
Sat, 3 Sep 2016 13:27:46 +0000 (15:27 +0200)
Now that all seama images are using the new build code this seama recipe
used with the old build code can be dropped.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/image/Makefile

index 39da5e09c0a791f1a3e11af2b0c6faf3627db4e0..7794d48482fb05984584b15e4de6a23eb3376cf3 100644 (file)
@@ -210,38 +210,6 @@ define BuildFirmware/DefaultDualSize/initramfs
        $(call BuildFirmware/OF/initramfs,$(1),$(2)-8M,$(3)-8M)
 endef
 
-# build Seama header images
-define BuildFirmware/Seama/squashfs
-       $(call MkImageLzmaDtb,$(2),$(3),$(5))
-       $(eval output_name=$(IMG_PREFIX)-$(2)-$(1)-sysupgrade.bin)
-       cat $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/root.$(1) > $(KDIR)/img_$(2).$(1).tmp
-       if [ `stat -c%s "$(KDIR)/img_$(2).$(1).tmp"` -gt $(5) ]; then \
-               echo "Warning: $(KDIR)/img_$(2).$(1).tmp is too big" >&2; \
-       else \
-               dd if=$(KDIR)/vmlinux-$(2).bin.lzma of=$(KDIR)/vmlinux-$(2).bin.lzma.padded bs=64k conv=sync; \
-               ( \
-                       dd if=$(KDIR)/vmlinux-$(2).bin.lzma.padded bs=1 count=`expr \`stat -c%s $(KDIR)/vmlinux-$(2).bin.lzma.padded\` - 64`; \
-                       dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
-               ) > $(KDIR)/vmlinux-$(2).tmp; \
-               $(STAGING_DIR_HOST)/bin/seama \
-                       -i $(KDIR)/vmlinux-$(2).tmp \
-                       -m "dev=/dev/mtdblock/2" -m "type=firmware"; \
-               $(STAGING_DIR_HOST)/bin/seama \
-                       -s $(call imgname,$(1),$(2))-factory.bin \
-                       -m "signature=$(4)" \
-                       -i $(KDIR)/vmlinux-$(2).tmp.seama; \
-               dd if=$(KDIR)/vmlinux-$(2).bin.lzma.padded bs=1 count=`expr \`stat -c%s $(KDIR)/vmlinux-$(2).bin.lzma.padded\` - 64` of=$(KDIR)/vmlinux-$(2)-sysupgrade.tmp; \
-               $(STAGING_DIR_HOST)/bin/seama \
-                       -i $(KDIR)/vmlinux-$(2)-sysupgrade.tmp \
-                       -m "dev=/dev/mtdblock/2" -m "type=firmware"; \
-               ( \
-                       dd if=$(KDIR)/vmlinux-$(2)-sysupgrade.tmp.seama; \
-                       dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
-               ) > $(BIN_DIR)/$(output_name); \
-       fi
-endef
-BuildFirmware/Seama/initramfs=$(call BuildFirmware/OF/initramfs,$(1),$(2),$(3))
-
 define BuildFirmware/PorayDualSize/squashfs
        $(call BuildFirmware/DefaultDualSize/$(1),$(1),$(2),$(3))
        if [ -e "$(call sysupname,$(1),$(2)-4M)" ]; then \