ramips: Add support for Netgear EX2700
authorJohn Crispin <john@openwrt.org>
Fri, 12 Feb 2016 08:29:33 +0000 (08:29 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 12 Feb 2016 08:29:33 +0000 (08:29 +0000)
This patch adds support for the Netgear EX2700 and builds an approriate
sysupgrade image.

What's missing is the option to build a factory image flashable via the
router's stock web interface, but this approach is hindered by the fact
that u-boot operforms an additional integrity check, which expects a
uImage header in the last 64 bytes of the "kernel" partition, which
the bootloader expects to be 960k, a size exceeded by the standard
OpenWrt kernel.

Signed-off-by: Joseph C. Lehner <joseph.c.lehner@gmail.com>
SVN-Revision: 48698

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/EX2700.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/mt7620/profiles/netgear.mk [new file with mode: 0644]

index c3a81a45136f7962fa01870b3c22e9f5c7e172f3..b10f5f1eba9329d86d87915df1aff56edfbebb11 100755 (executable)
@@ -125,6 +125,10 @@ dir-810l|\
 mzk-dp150n)
        ucidef_set_led_default "power" "power" "$board:green:power" "1"
        ;;
+ex2700)
+       ucidef_set_led_default "power_r" "POWER (red)" "$board:red:power" "0"
+       set_wifi_led "$board:green:router"
+       ;;
 f5d8235-v1|\
 f5d8235-v2)
        set_usb_led "$board:blue:storage"
index dafa3e98f1e02e485e19d6acfd0abf26496f4051..98537292b12566e5d7f40a5ba6ae940d4f27b625 100755 (executable)
@@ -141,7 +141,8 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "1:lan" "2:lan" "3:lan" "4:lan" "0:wan" "9@eth0"
                ;;
-       cf-wr800n)
+       cf-wr800n|\
+       ex2700)
                ucidef_add_switch "switch0" \
                        "4:lan" "6t@eth0"
                ;;
index acc500b70e280252e95fb2800ec616c60782350a..59c59653960dca86b7512813d01ea35088fe5c64 100644 (file)
@@ -34,6 +34,7 @@ get_status_led() {
        a5-v11|\
        d105|\
        dcs-930l-b1|\
+       ex2700|\
        hlk-rm04|\
        mpr-a1|\
        mpr-a2)
index 8025a408803629c11fd7695ee2abe69230000cf7..aed8350291da9a3b87c385099a89573661549769 100755 (executable)
@@ -154,6 +154,9 @@ ramips_board_detect() {
        *"ESR-9753")
                name="esr-9753"
                ;;
+       *"EX2700")
+               name="ex2700";
+               ;;
        *"F5D8235 v1")
                name="f5d8235-v1"
                ;;
index 39b5f94a76e7c372951fa24bc428e31f9ff15728..78edd221640647c1802e0cd530ce5a04fd5a746d 100755 (executable)
@@ -51,6 +51,7 @@ platform_check_image() {
        dir-810l|\
        e1700|\
        esr-9753|\
+       ex2700|\
        f7c027|\
        firewrt|\
        fonera20n|\
diff --git a/target/linux/ramips/dts/EX2700.dts b/target/linux/ramips/dts/EX2700.dts
new file mode 100644 (file)
index 0000000..4b5a01a
--- /dev/null
@@ -0,0 +1,148 @@
+/*
+ * Device Tree file for the Netgear EX2700
+ *
+ * Copyright (C) 2016 Joseph C. Lehner <joseph.c.lehner@gmail.com>
+ *
+ * This file is licensed under the terms of the GNU General Public
+ * License version 2.  This program is licensed "as is" without any
+ * warranty of any kind, whether express or implied.
+ */
+
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+/ {
+       compatible = "ralink,mt7620a-soc";
+       model = "Netgear EX2700";
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       palmbus@10000000 {
+
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+
+               gpio1: gpio@638 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "jedec,spi-nor";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "mx25l3205d";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@40000 {
+                                       label = "firmware";
+                                       reg = <0x40000 0x3b0000>;
+                               };
+
+                               art: partition@3f0000 {
+                                       label = "art";
+                                       reg = <0x3f0000 0x10000>;
+                                       read-only;
+                               };
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&art 0x0>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&art 0x1000>;
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       default {
+                               //  spi refclk: pins 37, 38, 39
+                               //       uartf: pins 8, 9, 10, 11, 12, 13, 14
+                               //         i2c: pins 1, 2
+                               ralink,group = "i2c", "uartf", "spi refclk";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power_g {
+                       label = "ex2700:green:power";
+                       gpios = <&gpio0 9 1>;
+                       default-state = "on";
+               };
+
+               power_r {
+                       label = "ex2700:red:power";
+                       gpios = <&gpio0 11 1>;
+               };
+
+               device_g {
+                       label = "ex2700:green:device";
+                       gpios = <&gpio0 13 1>;
+               };
+
+               device_r {
+                       label = "ex2700:red:device";
+                       gpios = <&gpio0 10 1>;
+               };
+
+               router_g {
+                       label = "ex2700:green:router";
+                       gpios = <&gpio0 12 1>;
+               };
+
+               router_r {
+                       label = "ex2700:red:router";
+                       gpios = <&gpio0 14 1>;
+               };
+
+               wps {
+                       label = "ex2700:green:wps";
+                       gpios = <&gpio1 15 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 1>;
+                       linux,code = <0x198>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 2 1>;
+                       linux,code = <0x211>;
+               };
+       };
+};
index 27f349f61904af5d7ca862494058e1e56f9dfc88..a42f8b9dbce9f3b6e39ac450aed13a80abc9e270 100644 (file)
@@ -913,6 +913,7 @@ endif
 #
 
 Image/Build/Profile/E1700=$(call BuildFirmware/UMedia/$(1),$(1),e1700,E1700,0x013326)
+Image/Build/Profile/EX2700=$(call BuildFirmware/Default4M/$(1),$(1),ex2700,EX2700)
 Image/Build/Profile/MT7620a=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a,MT7620a)
 Image/Build/Profile/MT7620a_MT7610e=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a_mt7610e,MT7620a_MT7610e)
 Image/Build/Profile/MT7620a_MT7530=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a_mt7530,MT7620a_MT7530)
@@ -958,6 +959,7 @@ Image/Build/Profile/TINY-AC=$(call BuildFirmware/Default8M/$(1),$(1),tiny-ac,TIN
 ifeq ($(SUBTARGET),mt7620)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/E1700,$(1))
+       $(call Image/Build/Profile/EX2700,$(1))
        $(call Image/Build/Profile/MT7620a,$(1))
        $(call Image/Build/Profile/MT7620a_MT7610e,$(1))
        $(call Image/Build/Profile/MT7620a_MT7530,$(1))
diff --git a/target/linux/ramips/mt7620/profiles/netgear.mk b/target/linux/ramips/mt7620/profiles/netgear.mk
new file mode 100644 (file)
index 0000000..d1b073a
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/EX2700
+       NAME:=Netgear EX2700
+       PACKAGES:=-kmod-usb-core -kmod-usb2 -kmod-usb-ohci -kmod-ledtrig-usbdev
+endef
+
+define Profile/EX2700/Description
+       Support for Netgear EX2700
+endef
+$(eval $(call Profile,EX2700))