libiconv: add all ASCII aliases
authorGergely Kiss <mail.gery@gmail.com>
Mon, 2 May 2016 00:46:33 +0000 (02:46 +0200)
committerJo-Philipp Wich <jo@mein.io>
Mon, 2 May 2016 17:35:35 +0000 (18:35 +0100)
This patch adds missing ASCII aliases to the libiconv stub in order to avoid conversion errors like https://github.com/openwrt/packages/issues/2373

Signed-off-by: Gergely Kiss <mail.gery@gmail.com>
package/libs/libiconv/Makefile
package/libs/libiconv/src/iconv.c

index 7d9ba4caf845de88c992189b917385b9f10ef709..97162617da7ad12a658a434b6c04d9878f677f8d 100644 (file)
@@ -11,7 +11,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiconv
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_LICENSE:=LGPL-2.1
 PKG_LICENSE_FILES:=LICENSE
index d2e19e3c45b9f822d3f9398412466849c818704d..c3cfefa3cc9a6ad78f93a14ba60ff6c66bb31383 100644 (file)
@@ -44,6 +44,15 @@ static const unsigned char charsets[] =
        "\003" "UTF-32LE"   "\0"
        "\006" "ASCII"      "\0"
        "\006" "US-ASCII"   "\0"
+       "\006" "ISO646-US"  "\0"
+       "\006" "ISO_646.IRV:1991"  "\0"
+       "\006" "ISO-IR-6"   "\0"
+       "\006" "ANSI_X3.4-1968"    "\0"
+       "\006" "ANSI_X3.4-1986"    "\0"
+       "\006" "CP367"      "\0"
+       "\006" "IBM367"     "\0"
+       "\006" "US"         "\0"
+       "\006" "CSASCII"    "\0"
        "\007" "ISO-8859-1" "\0"
        "\007" "LATIN1"     "\0"
        "\010" "ISO-8859-15""\0"